AddIn in ArcMap 10.2.2

2544
2
03-07-2016 05:42 AM
AsimAhmad1
New Contributor

Issue : AddIn button/tool force Arcgis 10.2.2 to close.

Development environment: Visual Studio 2013, .Net framework 4.5 (I tried with 4.0 also), Arcgis for desktop 10.3

Works fine on development machine with version in AddIn config file as 10.1 or 10.2 or 10.3

User environment: Arcgis 10.2.2. AddIn get installed with version in AddIn config as 10.1 or 10.2. I am able to see the tool bar and tools. The moment I click in map view after taking a command from my AddIn Arcmap window exits without any message.

Please help me in resolving the problem.

Thanks,

Asim Ahmad

0 Kudos
2 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

I would suggest trying Resetting your ArcGIS application profile​  and possibly removing and re-adding the addin. That could help eliminate any flakiness from version changes.  If those don't help (reboot as necessary too, of course) then it may be a oath issue to the python or other version of software used for development.

0 Kudos
FreddieGibson
Regular Contributor II

Have you tried stepping through your codes logic in Visual Studio? It sounds like you're getting an unhandled exception in your code that is causing ArcMap to crash. If the debugger doesn't allow you to step through the code navigate to C:\Program Files (x86)\ArcGIS\Desktop10.3\bin, open the ArcMap.exe.config file and check the you have debugging against .NET 4 enabled.

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

  <startup>

    <supportedRuntime version="v4.0.30319"/>

    <!--<supportedRuntime version="v2.0.50727"/>-->

  </startup>

0 Kudos