iPhone app not able to perform Route task in ios6

03-05-2013 04:46 AM
New Contributor
I m new to ios development , I have an iPhone app which was developed in early version of ios, it supported ios5.
As soon as I upgraded my ios to version 6, the routing in my application stopped working.

When I reset the ios to factory settings, the application works fine. But it won't run in ios6.

What is the technical reason for this. Are there any changes in binary files?

How do I over come this?

0 Kudos
4 Replies
Esri Regular Contributor
There is no technical limitation for routing between iOS 5 and iOS 6. Could you please provide more detail about this?

1. Which version of ArcGIS Runtime SDK for iOS are you using?
2. What is the error message?
3. Post a sample application so I can try to reproduce issue.

0 Kudos
New Contributor
hi Nimesh,

The APP was created in older version of esri library, this supported till ios version5 and all functions worked fine.
However after the update in iphone to version ios6, the application stopped working.

When i tried to load the old application in xcode 4.6.1 the old libraries were not supported, hence i had to use latest esri ios Sdk now with ArcGIS Runtime SDK for iOS v10.1.1.

when i run the application it gives error saying "ArcGIS.h" not found.

i have this line on my view controller header.

#import "ArcGIS.h"

0 Kudos
New Contributor
ok i figured out the problem, under user header search paths, i had updated the library path.
now i am facing this issue.

  cannot find protocol declaration for'AGSMapViewDelegate'

any idea...??
0 Kudos
Esri Contributor

  cannot find protocol declaration for'AGSMapViewDelegate'

any idea...??

AGSMapViewDelegate is deprecated and has been replaced by three protocols:
1. <AGSMapViewLayerDelegate>,
2. <AGSMapViewTouchDelegate> and
3. <AGSMapViewCalloutDelegate>

This helps us to use a specific protocol based on the functionality needed.

Hope this helps!
0 Kudos