Has anyone tested ArcGIS Runtime SDK for iOS with iOS 8 betas?

3884
14
Jump to solution
08-12-2014 04:03 PM
KristopherJohnson
New Contributor II

I learned today of an issue with Core Location in iOS 8: a new key or keys must be added to Info.plist to get Core Location to work. More information is available on these pages:

- iphone - iOS 8 : Location Services not working - Stack Overflow

- rdar://17465666: Apps built for iOS 7 don't ask for location permission

- fixes #481: update CL tracking API for iOS 8+ · 8d6b14a · mapbox/mapbox-ios-sdk · GitHub

I'll note that I have not tested this myself, nor thoroughly investigated the issue. This may be nothing, but I'm curious as to whether ArcGIS developers or users of the SDK have tested their apps with iOS 8.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
DiveshGoyal
Esri Regular Contributor

We've been testing the Runtime SDK for iOS with iOS 8 Beta 5, and so far we've uncovered only a few issues mostly related to popup display on iPad in a form sheet or a page sheet presentation style. We've also run into the location display issues you report, caused by the new authorization model for using location in apps.

View solution in original post

0 Kudos
14 Replies
DiveshGoyal
Esri Regular Contributor

We've been testing the Runtime SDK for iOS with iOS 8 Beta 5, and so far we've uncovered only a few issues mostly related to popup display on iPad in a form sheet or a page sheet presentation style. We've also run into the location display issues you report, caused by the new authorization model for using location in apps.

View solution in original post

0 Kudos
KristofferStenersen
Occasional Contributor

Hi Divesh Goyal‌.

Now that Apple released the ios8 gm sdks, I´m still facing regular crashes in runtime sdk for ios with the following trace: gist:9f99e5f90256ab6e4c51

0 Kudos
DavidLednik
Occasional Contributor II

Hi Kristoffer,

is this a secured layer?

I'm trying to run some tests and I get an 400 error - bad request with the WMTS URL you provided.

0 Kudos
KristofferStenersen
Occasional Contributor

Hi David Lednik‌. This should not be a secured layer; the following should work:

AGSWMTSLayer.wmtsLayerWithUrl(NSURL(string:"http://opencache.statkart.no/gatekeeper/gk/gk.open_wmts"), title: "topo2", imageFormat: AGSImageFormat.PNG24, tileMatrixSet: "EPSG:32633")

But, upgrading to 10.2.4, I believe the issues I saw no longer occur. If i do find any more though, I´d be happy to share my project. If you have a BitBucket account, I can share it if the issue reoccurs.

Thanks for looking into this!

Kristoffer

0 Kudos
KristofferStenersen
Occasional Contributor

Hi again, actually I was able to crash my simulator on 10.2.4 (in "AGSFileFormatForImageFormatWithJPEGEqualToJPG") just after my previous posting.

0 Kudos
DavidLednik
Occasional Contributor II

Hi Kristoffer,

I tried your layer in 10.2.4 and I didn't see any crashes.

I just modified the sample map demo that comes with SDK installation.

Added this code to add the layer:

AGSWMTSLayer *wmtsLayer = [AGSWMTSLayer wmtsLayerWithUrl:[NSURL URLWithString:@"http://opencache.statkart.no/gatekeeper/gk/gk.open_wmts"] title:@"topo2" imageFormat:AGSImageFormatJPG tileMatrixSet:@"EPSG:32633"];

    [self.mapView addMapLayer:wmtsLayer];

I also tried JPEG and PNG24 formats with same result. I can browse the map with no issues.

Screen Shot 2014-11-03 at 10.19.28.pngScreen Shot 2014-11-03 at 10.19.48.png

0 Kudos
DouglasBocking
New Contributor

Has this been this been fixed in the newest Runtime SDK? I'm currently having problems with Core Location in iOS 8 in my app. I've added the keys suggested and it still wont work.

0 Kudos
KristofferStenersen
Occasional Contributor

Afaik, the issue I´ve seen is not related to location.

0 Kudos
ShiminCai
Occasional Contributor II

Hi Divesh,

I'm having the same location service issue after migrating to Xcode 6.1 iOS 8.1. I'm using ArcGIS Runtime SDK for iOS 10.2.4. Any suggestions please?

Thanks,

Shimin

0 Kudos