FeatureLayer not displaying all features - example: road segments randomly not displaying. Is there a limitation to the number of records allowed. This is in an Offline Geodatabase.

669
2
03-09-2017 08:42 AM
GaryWine
New Contributor

I have an offline Gdb that I use and I have noticed that random segments of my roadcenterlines will not display when I pan to them. However, when I pinch the device screen, those segments appear, but I pan away and come back and they are invisible again. I also noticed that labels for roads, again random, do not display. Nothing I do makes this change. My Spatial Reference is matching with the MapView and my FeatureLayer.

I have attached an image, if you can see it, where there is a broken segment on the road running NW from the intersection. Once again, if I pinch the screen it will appear. If I pan away and back to it, it disappears.

0 Kudos
2 Replies
AlexanderNohe1
Regular Contributor II

That is interesting behavior that you are seeing.

What version of the runtime are you using?  How many features exist in this centerline feature class in your offline GeoDatabase?

What type of device are you using?  Can you reproduce with an emulator?

0 Kudos
GaryWine
New Contributor

My apologies for not responding to this. I used our main account when I posed this question.

I have not tried an emulator.

Device is a Samsung SM-P900 Lollipop 5.0.2

The FeatureLayer is a dissolved roadcenterlines fc of 3274 Features (Polylines of course)

ArcGIS 10.3.1 with runtime enabled. Have not upgraded 10.5.1 yet, waiting on Server upgrades first.

0 Kudos