Runtime SDK for Android (v100) is not compatible with x86 phones

415
0
03-06-2018 04:21 AM
SalihYalcin
New Contributor III

Hello Everyone, 

The Android SDK with version 100 and higher is not compatible with phones that have x86 architecture. When I tried to open the app which developed with Esri Android 100.1.0 it can't open from x86 devices but I am able to open and run same application from x64 device. Could you guys considering add a support for this ? I remember that version v10.2 has this issue too but you guys solve and we are able to use sdk over all devices. 

Here is the LogCat from device. 

03-06 15:01:43.032 18982-19014/? E/AndroidRuntime: FATAL EXCEPTION: GLThread 1499
Process: com.esri.arcgisruntime.sample.displaymap, PID: 18982
java.lang.RuntimeException: createContext failed: EGL_BAD_CONFIG
at android.opengl.GLSurfaceView$EglHelper.throwEglException(GLSurfaceView.java:1192)
at android.opengl.GLSurfaceView$EglHelper.throwEglException(GLSurfaceView.java:1183)
at android.opengl.GLSurfaceView$EglHelper.start(GLSurfaceView.java:1033)
at android.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1400)
at android.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1239)‍‍‍‍‍‍‍‍


Thanks for all. 

doneill-esristaff

0 Kudos
0 Replies