Unable to access Enterprise portal rest endpoint

442
0
10-23-2023 06:16 PM
Labels (1)
GIS412
by
New Contributor III

Hello,

I'm trying to access a rest endpoint using javascript. I have generated an API key from the developer portal. The rest endpoint I need to access is on our ArcGIS Enterprise Portal.

When I use the Enterprise Portal rest endpoint url in my code, I'm seeing nothing populate on my map.

I then tested this endpoint via Postman and get this result:

<!DOCTYPE html>
<html>

<head>
    <script src="login/config/dojo.js"></script>
    <script src="jsapi/dojo/dojo.js"></script>
    <script>
        require(["login""dojo/domReady!"], function(login) {
      login.run();
    });
    </script>
</head>

<body>
</body>

</html>
 
Since I am unable to get any data back from this rest endpoint I decided to test another rest endpoint. This url comes from our ArcGIS Online portal. When I insert this rest endpoint url into my code, I am able to see point data appear on my map. When I use this url through Postman, I'm getting an html representation of the rest endpoint. I cannot link the result as the data is sensitive. This seems to be working.
 
I've checked both projects. Both are sharing settings are set to organization. As far as my groups within my ArcGIS portals (online and enterprise) I am in all groups within my organization (I have admin level privileges).
 
Why am I unable to pull data from a rest endpoint from an Enterprise Portal? Does this have something to do with my developer subscription plan (Do I need the professional plan)? What am I missing?
0 Kudos
0 Replies