ArcGIS Pro Startup Page Silhouette Issue

357
6
05-05-2021 03:31 PM
JoeMadrigal
New Contributor III

I'm using the latest software version ArcGIS Pro 2.7.3.  My startup page has a white rectangular silhouette that covers part of the page.  This also happens when I program a custom start page.  It sort of looks like the same size as one of my panes that is docked to the right of the screen.  Any idea how I debug this and get that removed?

Its quite obvious, I don't think I need to circle it:

arcgispic.jpg

 

0 Kudos
6 Replies
Wolf
by Esri Regular Contributor
Esri Regular Contributor

Hi Joe,

 I tried this using Pro 2.7.3 and I can't duplicate your issue, however, I had a similar issue with Outlook about a month back where I saw a similar 'silhouette'  across the top of my outlook window.  After I updated my OS and video drivers the problem went away.  

Here's my startup screen:

Wolf_0-1620323289677.png

 

0 Kudos
JoeMadrigal
New Contributor III

Thanks for the tip.  I'll check my drivers although one of my colleagues is seeing the same thing.  If I remove all my add-ins, it goes away.  If I reinstall my add-in that I have been developing, I see it again.

0 Kudos
Wolf
by Esri Regular Contributor
Esri Regular Contributor

Ok that narrows it down.  Can you try to figure out which add-in is causing the issue and then share the config.daml for that add-in?   

0 Kudos
JoeMadrigal
New Contributor III

Its actually my add-in I'm creating.  Ugh, I need to strip down the config.daml so I share it.  I'll keep working it. Thanks.

0 Kudos
JoeMadrigal
New Contributor III

@Wolf With your hint I nailed it down to one of my panes in my Add-in.  I have a webbrowser control inside my pane.  If I remove it, the the white rectangle goes away.  I'm using it so I can print html status messages to a console like window (my pane).  Maybe ArcGIS doesn't support webbrowser control inside pane in this way?  I'll have to think of an alternative way to display html if I can't fix.

<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="*"/>
<RowDefinition Height="Auto"/>
</Grid.RowDefinitions>
<WebBrowser Grid.Row="0" x:Name="webConsole" Margin="10,5,10,0" ui:BrowserBehavior.Html="{Binding HtmlToDisplay}"/>
<ProgressBar Grid.Row="1" x:Name="ProgressBar" HorizontalAlignment="Left" Width="150" Height="10"
Margin="10, 5, 0, 5" IsIndeterminate="{Binding IsProgressIndeterminate}"
Visibility="{Binding IsProgressVisible, Converter={StaticResource BoolToVisibility}}"/>
</Grid>

 

0 Kudos
Wolf
by Esri Regular Contributor
Esri Regular Contributor

I will take a look at this.  As a workaround: ArcGIS Pro is using the Chromium Web Control and you can find a sample (also using a pane) here:  arcgis-pro-sdk-community-samples/Framework/ChromiumWebBrowserSample at master · Esri/arcgis-pro-sdk-...  and some documentation about the browser control here:  ProConcepts Framework · Esri/arcgis-pro-sdk Wiki (github.com)

0 Kudos