XY to Line attribute table is all <NULL>

235
3
08-15-2018 06:23 PM
GabrielMarcus1
Occasional Contributor II

I've got two point features that I am comparing. Both represent physical structures.

The following was my workflow:

1) reprojected features to WGS 84 (4326)

2) I added fields for X and Y values and calculated geometry appropriately

3) joined the first table to the the second

4) Ran XY To Line, and included and ID that was the structure building number

Line Type: Geodesic

ID: buildingID

SpatialRef: GCS_WGS_1984

Results: 

XY to Line created the lines, but ALL attributes are <NULL> and the ID field didn't appear. 

There were NO errors. 

Questions:

Why are the attributes <NULL>? 

Where's my ID field?

0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

make the join permanent by saving to a new featureclass... I suspect the join is dumped during output creation

GabrielMarcus
New Contributor II

That worked. It's too bad that step doesn't appear in the documentation. 

DanPatterson_Retired
MVP Esteemed Contributor

Glad it worked out... 

I have just gotten into the habit of making joins permanent every time... you can always delete what you don't want after you are done.

0 Kudos