Why is the Legend left alignment off in Pro

88
2
03-17-2020 01:54 PM
BradAllen1
New Contributor

My Legend item in a layout.  For the example pics attached the bottom left corner of my layout is at 1" x 1" and the bottom right is at 8" x 1".  My legend has a 0.1" gap on the border and the back ground.  When I put the Legend bottom left corner at 1.1" x 1.1" it doesn't line up.  When I put it on the right side and set the bottom right corner to 7.9" x 1.1" it lines up great.  I can see that the selection box for the legend Item seems to be slightly off on the left side.

Thanks in advance for any help

Tags (3)
0 Kudos
2 Replies
TomBole
Esri Regular Contributor

Hi Brad, 

This looks like a bug. A quick examination makes me believe that the Legend title, even when not displayed, is affecting the gap on the left.  I'll follow up on this and confirm that this is a bug. If you want want to track this issue please contact Esri Support. They can be contacted at https://support.esri.com/en/contact-tech-support.

In the meantime, you should be able to create guides and snap the legend to position you want. Please see Page setup—Layouts | Documentation for more information.

Thanks for the feedback, 

Tom

0 Kudos
AubriKinghorn
Esri Contributor

Hi Brad,

I work with Tom, and we've been looking at the issue. What you're seeing is most likely due to any indents set on the legend items. Legend items are given an automatic indent of 5 pts. This is easy to see if the legend title is turned on. Setting the indent to 0 may be helpful in your case. We are looking at removing the automatic indent, and improving the aligning experience for items with borders and gaps in future releases of ArcGIS Pro. I hope this helps.

Cheers,

Aubri Kinghorn

0 Kudos