Utility Network Trace GP Service

69
0
01-27-2021 01:10 PM
JW_Mapguy
New Contributor II
I tried to run a simple trace in Pro (v2.6), then export that as a GP service; however, I received a message when analyzing the tool before publishing, saying that the data source is not registered with the server, and the data will be copied over….which is odd because the trace tool is run off the Utility Network that was published as part of the feature service in Portal. You can’t run a trace on an SDE dataset. When I bypassed that issue by checking the box to copy over the data (still not sure what actually got copied over), the service published but the GP service won't run the tool properly.
 
Has anyone been able to publish a trace tool as a geoprocessing service to use as a GP widget in an app in Portal? I tried a connect trace, which has very few parameters, but when I ran it in the app I got a ton of errors, saying Implementation of this Tool's Validate is invalid. The server logs did not yield much more info.
0 Kudos
0 Replies