Using Copy tool in python window deletes output file geodatabse

304
3
11-03-2021 06:38 AM
ChrisStiwinter1
New Contributor II

ArcPRO 2.8.3

Origin database:  Oracle 12CR1 

Destination: file geodatabase

Error: tool fails and output file geodatabase is automatically deleted. 

Below is copy of output form python using copy tool:

arcpy.management.Copy("C:\\Users\\cstiwint\\appdata\\Roaming\\Esri\\Desktop10.6\\ArcCatalog\\SDE User - oak-db-test-ENERGY.sde\\ENERGY.Bldgs","I:\\Chris\\Working\\one.gdb")
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\management.py", line 6201, in Copy
raise e
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\management.py", line 6198, in Copy
retval = convertArcObjectToPythonObject(gp.Copy_management(*gp_fixargs((in_data, out_data, data_type, associated_data), True)))
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\geoprocessing\_base.py", line 512, in <lambda>
return lambda *args: val(*gp_fixargs(args, True))
arcgisscripting.ExecuteError: ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
The connection property set was missing a required property or the property value was unrecognized.
ERROR 000260: Failed to copy C:\Users\cstiwint\appdata\Roaming\Esri\Desktop10.6\ArcCatalog\SDE User - oak-db-test-ENERGY.sde\ENERGY.Bldgs into I:\Chris\Working\one.gdb
Failed to execute (Copy)

0 Kudos
3 Replies
Steve_Salas
Occasional Contributor

I think this will be successful if the output path includes the name of the feature class rather than just the FGDB you are copying into.  Try this:

arcpy.management.Copy("C:\\Users\\cstiwint\\appdata\\Roaming\\Esri\\Desktop10.6\\ArcCatalog\\SDE User - oak-db-test-ENERGY.sde\\ENERGY.Bldgs","I:\\Chris\\Working\\one.gdb\\Bldgs")

I tried it this way first with my own data (Ent. GDB is 10.7.1 on Oracle 19) and was successful.  Then I noticed you only specified the output FGDB with the second parameter.  I tried that and it does delete the output FGDB.  I have the option set to "True" overwrite existing output datasets... so you could try turning that off as well if it is set in your Geoprocessing options and at least it might not delete your FGDB... and then failing!

0 Kudos
ChrisStiwinter1
New Contributor II

Thanks for the reply Steven.   Your answer did correct the issue of deleting out the file geodatabase but i am still running into issues with this tool..

A few things-

1.  If the feature class has any attachments then the tool still seems to fail  Error 000260

2.  If I run the tool for an entire dataset (and include FEATUREDATASET as a parameter the tool fails with underlying DBMS error (ORA-01790).

Any ideas are much appreciated...

0 Kudos
Steve_Salas
Occasional Contributor

Upgraded to Pro 2.8.2, still on 10.7.1 Oracle 19

Testing with a feature dataset:  If I include the "FEATUREDATASET" parameter, the feature dataset and contents successfully copy, but the feature classes now have a "_1" appended to the end of the name.  If I omit the "FEATUREDATASET" parameter, the copy is also successful and names remain the same as found in the enterprise GDB.

Testing with attachment:  copy was successful

We have slightly different environments and certainly different data so you might need to engage ESRI support to take a closer look