.style to .stylx confusion (ArcPro)

1824
11
03-02-2018 06:25 AM
SofiaThordin2
New Contributor II

Hi! I just got upgraded to ArcPro and am experiencing some growing pains. I had a set .style connected to ArcMap that included all of Florida DOT's official road signs. I want to add that style to ArcPro and have followed these instructions to import it. It seems to go through without a hitch, but after importing I still don't see the option to use that stylx anywhere. In the symbology/character properties, the style does not appear. When I try to work around and add the stylx from the project folder (styles>add style) it tells me I already have the style added. 

This makes sense, since I already "imported" and it should add to the project automatically, but HOW do I get the stylx to come up as an option in my symbology/character properties??? In ArcMap, I usually do this. Layout View>Drawing Toolbar>Draw Marker>Right click marker properties>Symbol selector>Choose from my connected style folder (see below)

This style does not appear anywhere in ArcPro when I add a marker in Layout. I only have the options of ESRI markers. I know I can create essentially the same markers by editing the basic ESRI marker and adding text on top, it's just in the long run I would really like to have this set up. For clarity, I have been working with the below features in Pro: 

I'll probably end up creating the road signs from scratch using ESRIs default this time around, but eventually I'd like to resolve this. 

Thanks in advance for those of you who read and respond!

EDIT: Okay, so these markers are based on a custom font type. So it turns out I am able to find *some* of the symbols in Point>format point>shape marker>font style. This isn't really what I want, since I still need to manually choose the colors and stuff, but it's better than nothing

0 Kudos
11 Replies
KoryKramer
Community Moderator

Sofia, the workflow you describe puts you in the layout.  So when you click the dropdown for point symbols, you don't see yours in there?

I added the ArcGIS Explorer style to my project and when I click on the Point dropdown in the Graphics group in Layout, I see this:

SofiaThordin2
New Contributor II

Right, I can see the style in catalog, but it doesn't come up anywhere else. Does that make sense? I don't know. It's named ddvfl13a and I don't see that in any point dropdown

0 Kudos
KoryKramer
Community Moderator

Are they in your text symbols?

0 Kudos
SofiaThordin2
New Contributor II

Well, sort of. The style is based off a custom font, so that font does show up if I choose the "font" symbol option. However, all of the formatting is gone. For example, the highways shields should be red and blue with white outlines, but when I choose it from the font selector it is completely black, with no number or anything. Which means that I have to go in and customize it each time I want to add it to a layout-- right? Sorry, I'm still getting used to using Pro

"Font" symbol in ArcPro:

Versus "symbols" in ArcMap:

0 Kudos
KoryKramer
Community Moderator

I'm not sure, Sofia. I'm asking around...

ChrisDonohue__GISP
MVP Frequent Contributor

One possibility that comes to mind from using the California Highway Shields set (ddvca), which sounds similar in nature - since it is based on custom fonts, you may have to load the fonts onto the computer that is being used.  So it is not just installing the style, but a second step of adding fonts to Windows.

Chris Donohue, GISP

SofiaThordin2
New Contributor II

Thank you for the tip, I have the fonts saved to my standard fonts folder on my local Windows drive. Unless I need to re-install them, I believe they should be good to go. 

0 Kudos
EdiePunt
Esri Contributor

Hi Sofia,
When you right-click on the style in the Catalog pane, is the command to Upgrade available? In Pro, styles have versions, and the version must match the Pro version. This was not the case in ArcMap. If it's not at the correct version, that cuold be one reason why the symbols aren't showing up. If that is not the issue, could you send me the style and the font? I'd like to see if I can reproduce what you are seeing. 

Edie

0 Kudos
SofiaThordin2
New Contributor II

"Upgrade" is grayed out, so I am assuming that is not the issue. I am attaching a link to the zip of the files with font and instructions and .style. Let me know what you figure out! WeTransfer 

0 Kudos