Stream Link error for hydrology analysis

718
6
Jump to solution
07-12-2021 08:53 AM
MohamadJouni
New Contributor III

first, I try to convert my "set null dem of flow direction" to stream link but the problem I have that not all raster of my dem  converted to steam link soo why that happens ?

note that: I use both ArcGIS pro 2.5 and ArcMap 10.8 and get the same problem

See picture below :  

Capture.PNG

  

2.PNG

0 Kudos
1 Solution

Accepted Solutions
NawajishNoman
Esri Contributor

Hi Mohamad,

Can you please specify a numeric value 1 (or any number) in the false raster parameter instead of the flow accumulation raster? 

The stream raster from Con or Set Null does not need the flow accumulation values. It can just be one value.

Steam Link will assign unique values to each reach.

Thanks

Noman

 

View solution in original post

6 Replies
NawajishNoman
Esri Contributor

Hi Mohamad,

Could you kindly post the expression you used in the Set Null tool? 

I usually use the Con tool to apply a threshold to flow accumulation raster to create a stream raster, which I then use to Stream Link tool.

You can try the Con tool instead of the Set Null to see if it helps. If nothing works, I would be interested to get your data for taking a closer look if you can share.

Thanks

Noman

0 Kudos
MohamadJouni
New Contributor III

Hi Nawajish

first, thank you for helping me 

second set null work correctly but convert "set null dem to stream link" make issue like show in the picture above and I try con tools and get the same issue

and here more picture to see what is going on 

2.PNGCapture.PNG

 

0 Kudos
NawajishNoman
Esri Contributor

Hi Mohamad,

Can you please specify a numeric value 1 (or any number) in the false raster parameter instead of the flow accumulation raster? 

The stream raster from Con or Set Null does not need the flow accumulation values. It can just be one value.

Steam Link will assign unique values to each reach.

Thanks

Noman

 

View solution in original post

MohamadJouni
New Contributor III

Thank you so much it works correctly when I change to 1

note that before you solved my problem when I use in my Set null expression value<=100000 it's working correctly without any mistake

I think this error comes from long-range of numbers when I Set null expression value<=1000

NawajishNoman
Esri Contributor

Hi Mohamad,

I am glad it is working for you.

Is it possible for you to share the data with me so that we can test and see why you missed a few streams with a small threshold value?

 Thanks

Noman

 

0 Kudos
MohamadJouni
New Contributor III

yes I will share my dem map and hydro tools today as soon as possible and wait for you to solve problem

0 Kudos