Spacebar Zooms to World Instead of Suspending Snapping (during editing)

1074
7
06-04-2021 01:24 PM
Labels (1)
JimThomas1
New Contributor II

I'm using Pro to edit a line feature service.  I use the spacebar to turn off snapping.   Initially, using the spacebar to suspend snapping was working normally, then about an hour into editing, using the spacebar during editing would zoom out to the entire world.  Why would this happen, and how do i correct it?

Closing and relaunching did not help.

0 Kudos
7 Replies
DanPatterson
MVP Esteemed Contributor

Keyboard shortcuts for editing—ArcGIS Pro | Documentation

press spacebar and hold ... indeed does turn on/off snapping.

however, pressing the spacebar also "execute a command" 

ArcGIS Pro keyboard shortcuts—ArcGIS Pro | Documentation

Did you stop/start editing or anything else within your hour of editing?

You suggest that the unwanted state persists even after saving and restarting.

If this is the case, does it do it for shorter edit sessions?  If so, you might want to contact Tech Support to see if anyone else has reported this behaviour.


... sort of retired...
0 Kudos
JimThomas1
New Contributor II

Still having problem.  After about an hour of editing, the space starts zooming to the world during editing when it should pause snapping.  This was happening in Version is 2.7.0 but i've updated to 2.8.0 today and will see if the issue happens again.

0 Kudos
DanPatterson
MVP Esteemed Contributor

IF that doesn't fix it, contact Tech Support.  It could be an issue or something about your environment


... sort of retired...
0 Kudos
JimThomas1
New Contributor II

When the problem occurred Friday, I saved and closed the project, then relaunched.  Still had same issue with spacebar zooming to the world.  Over the weekend, i shutdown.  Restarted this morning.  No issue at the moment... the spacebar temporarily turns of snapping.  We'll see what happens an hour from now...

0 Kudos
morrischris
New Contributor

@JimThomas1 wrote:

When the problem occurred Friday, I saved and closed the project, then relaunched.  Still had same issue with spacebar zooming to the world. checked with spacebar clicker and the spacebar key works fine.  Over the weekend, i shutdown.  Restarted this morning.  No issue at the moment... the spacebar temporarily turns of snapping.  We'll see what happens an hour from now...


Facing the same issue since morning... has anyone found a solution to this? is it fixed? Please help, i gotta complete this project before the deadline! 😞

0 Kudos
PatrickCote
New Contributor II

We also have a user who experiences the same issue sporadically. We can't find a pattern when it happens, but when it does, it takes many reboot of ArcGIS Pro to get ride of the behavior.

When editing or creating new features, the user presses on the spacebar to temporarily disable snapping but it zooms out. It still disables snapping, but it is really annoying for the user.

He also experiences a similar problem sometimes while trying to delete a feature. After selecting the feature, he would press on the delete button on his keyboard. It then applies a zoom to extent before deleting the feature.

Any idea what could cause this?

AnnHowland1
New Contributor II

I also have this issue.  Use suspend snapping by using the spacebar during vertex edits of building footprints, after a few edits, the spacebar method ceases to work.  Then I have to put my cursor up to the Snapping button and turn it off, complete my vertex edits, then turn it back on for a different vertex.  Highly annoying.  I am using 3.2.0 version.  Had the same issue in 3.1.3 and finally upgraded to see if new version would fix it.  Nope!

0 Kudos