Show features created in Branch version in Local Scene

332
2
Jump to solution
10-19-2021 08:35 AM
Labels (3)
SergueiSokolov
New Contributor III

We edit features using Electric1 Utility Network (UN) feature service in a branch version. All works in 2D Map. We have also created a Local Scene to show the UN features in 3D. In both views (2D map and Local Scene) the UN Feature Service was switched to use the same branch version. The challenge is that Scene view does not render features (such as Structure Points and Devices) that were created in the same branch version (i.e. user placed a pole in 2D map). However, Scene View does show 3D rendering of similar existing UN features (from the SDE.DEFAULT) correctly. Does ArcGIS Pro Local Scene view support rendering of UN features created in a branch version?

If yes, are there any specific settings that we have missed? We tried to create UN features with Z set to 0 (On the Ground Elevation settings) and Z real world value (with "At Absolute Height" layer's settings). We have tested with AGE10.9, Electric1 Utility Network Feature Service and ArcGIS Pro (v 2.7.4) 

0 Kudos
1 Solution

Accepted Solutions
RemiMyers
Esri Contributor

Hi Serguei;

I am not aware of any limitations with branch versioning features rendered in Scene.  As always, your best approach is to reach out to Esri Support to be certain that you are not running into a system issue.   For feature configuration guidance, I can walk you through some recommendations (just set up a meeting) and to better document the specific UN configurations (usually a function of device or equipment configuration) I will follow up with a blog on best practices for configuring the UN in 3d later this week.

Edit: The below screengrab is a 3d UN project in a branch in a child version 

RemiMyers_0-1635192213886.png

 

View solution in original post

2 Replies
RemiMyers
Esri Contributor

Hi Serguei;

I am not aware of any limitations with branch versioning features rendered in Scene.  As always, your best approach is to reach out to Esri Support to be certain that you are not running into a system issue.   For feature configuration guidance, I can walk you through some recommendations (just set up a meeting) and to better document the specific UN configurations (usually a function of device or equipment configuration) I will follow up with a blog on best practices for configuring the UN in 3d later this week.

Edit: The below screengrab is a 3d UN project in a branch in a child version 

RemiMyers_0-1635192213886.png

 

SergueiSokolov
New Contributor III

Hi Remi

I appreciate your clarification. It assured that we are on the right track. Further testing confirmed that rendering of new features created in a branch version UN works as expected in the 3D Local Scene. We had to adjust settings in the scene's symbology as per your recommendations (see a screenshot below).

Thank you!

0 Kudos