Sharing Web Layer: Error 00062

357
3
Jump to solution
10-23-2020 09:10 AM
SteveCole
Frequent Contributor

I cannot find any more information about this error and what to do about it. Backstory:

In ArcGIS Pro, I have a very simple map I imported from Arcmap: one point layer located in SDE "A" and one table located in SDE "B". When I attempt to use the Share Layer As Web layer Tool to publish this to our Portal, the Analyze button reports back Error 00062: "Map contains data that does not use the same connection to an enterprise database (Web Feature Layer)".

So- what do I do? I'm using ArcGIS Pro 2.4.1

Steve

0 Kudos
1 Solution

Accepted Solutions
JonahLay
Esri Contributor

Hi Steve,

In addition to Robert's response, you can address this error by following the solutions listed here: 00062: Map contains data that does not use the same connection to an enterprise geodatabase

Best,

Jonah

View solution in original post

3 Replies
Robert_LeClair
Esri Frequent Contributor

It seems AGP is trying to publish both the spatial and non-spatial table in one GP operation.  What you could do is right-click on the point layer and select Sharing-Share as Web Layer.  This will share ONLY the selected layer in your Contents Pane.  Repeat for the table.  Then both layers are published as individual hosted feature layers.  Good luck!

JonahLay
Esri Contributor

Hi Steve,

In addition to Robert's response, you can address this error by following the solutions listed here: 00062: Map contains data that does not use the same connection to an enterprise geodatabase

Best,

Jonah

View solution in original post

SteveCole
Frequent Contributor

Thanks, guys. I marked Jonah's response as correct since his link explicitly states why this error was happening. I realized after posting that I had dealt with this before and my workaround was to take the table, convert it to an Excel file, and then upload that into Portal and turn it into a service. That's what I'll be doing here as well.

Thanks again.

Steve