Setting up Deep Learning in ArcPro 2.7?

142
1
03-04-2021 01:19 PM
Labels (1)
GISArchbold
New Contributor II

I am trying to get the Deep Learning tools set up to perform a pixel based classification in ArcPro 2.7. As everyone else I've seen on these forums, I downloaded the installer at:

https://github.com/Esri/deep-learning-frameworks/blob/master/README.md?rmedium=links_esri_com_b_d&rs...

In working through the Palm Tree example and my own data, I get a consistent error that I'll post an image of, but my main question is, do you have to follow the instructions to clone the default conda environment if you use the installer for Pro 2.7? Based on the documentation, and a comment made in this thread a couple of weeks ago, it isn't necessary.

https://community.esri.com/t5/arcgis-pro-questions/train-deep-learning-model-error/m-p/190300

Basically I haven't been able to find this particular error in any documentation or other questions asked, and I'm not sure where the issue could be coming from (unless I'm misreading the installation instructions and I skipped a vital step by not cloning the conda environment).

The error is from the Train Deep Learning Model tool.

 

Tags (2)
0 Kudos
1 Reply
DanPatterson
MVP Notable Contributor

There is so much with the deep learning stuff, I would recommend the clone route and the install packages in your first link.  That is no guarantee that things will work in any event, especially if you have messed up your base/main environment


... sort of retired...
0 Kudos