Set aliases doesn't work on sql table

12-03-2021 02:35 AM
Labels (2)
New Contributor III

Hi at all,

I'm trying to set aliases on layers, bu it doesn't work.

The layers are based on sql tables, wich contains the geometry and attributes.

I tried to change the aliases with python at first, because I would like to do this in bulk, but the edit field function always throw the error "Error 001625 failed to alter field is nullable". This error didn't made sense to me, as I wasn't trying to change null-ability on the field.

After python didn't work, I was searching for other ways to set the alias. One thing I did was trying to manually set it. So I right clicked on one layer -> design -> fields, and set an alias on one field.
After this, I confirmed that the field would be displayed in dropdowns with its alias, wich it did.
But after saving, closing and reopen the document, the alias was gone. It tried this a couple of times to confirm that the alias is not saved.

This document is also published on an arcgis portal, i also tried to set the alias there, but on portal I cant even edit the field as the options to edit are missing in the portal elements.

Is there another way to give my layers, wich are based on sql tables, aliases?
Converting the data to a gdb is not possible, as the sql tables are frequently updated from another system, and the layers/services are supposed to show this updated data. 

kind regards, 


0 Kudos
1 Reply
MVP Regular Contributor

Hello Sebastian,

Are you trying to set the aliases on a feature service?

I would try stopping the service, editing the feature class from the database and setting the aliases, then restart the services.  You may even have to republish / overwrite the services to apply the schema change.

Amanda Bishop, GISP
0 Kudos