Select to view content in your preferred language

Security Alert when Using Esri Basemaps

440
1
05-31-2023 01:30 PM
cdevault_pickett
New Contributor III

We have been experiencing an odd issue for a while now when using Esri Basemaps in ArcGIS Pro (currently 3.0.3) but has been happening since 2.9. We are using a custom basemap gallery with ArcGIS Enterprise 10.9.1. When opening an ArcGIS Pro Project that uses Esri Basemaps this Security Alert appears saying "you are about to view pages over a secure connection."

cdevault_pickett_0-1685564656169.png

I installed Fiddler and monitored the traffic, finding that every time this window pops up these HTTP responses show up using a 301 code stating "301 Moved Permanently". I suspected this was potentially caused from our basemaps were not the most recent vector basemaps. So I double checked what is available in AGOL right now to what is used in our Portal. They are exactly the same. It only seems to be triggered when the Service Layer Credits are accessed whether that is from the button in the map view or from a layout with a Service Layer Credits Dynamic Text Box. 

cdevault_pickett_1-1685564777546.png

Does anyone have any guidance on how to fix this issue?

 

0 Kudos
1 Reply
cdevault_pickett
New Contributor III

Going to document our findings as we were able to resolve this issue. In the Windows Internet Properties, on the Advanced tab there is a setting that we had checked called Show friendly HTTP error messages. Once unchecked this problem stopped. 

cdevault_pickett_0-1690476768654.png

 

0 Kudos