Searching for Intersections Using a Pro Locator

230
6
06-02-2021 07:53 AM
Labels (1)
MattFancher1
New Contributor III

I created a locator in Pro 2.8 using "Create Locator". The locator includes both a point address and street address role. It works great in Pro searching for an intersection, as shown in this example:

MattFancher1_0-1622644873826.png

The results are different when the locator is published as a geocode service to a stand-alone 10.7.1 ArcGIS Server site. For illustration purposes I configured the geocode service in the search widget of a Web AppBuilder app. The same search criteria don't return an intersection result there:

MattFancher1_1-1622645113740.png

However, if I included the street type as shown below I get the desired result:

MattFancher1_2-1622645196613.png

Any ideas why? Is this a configuration issue or just something that isn't supported when publishing locators from Pro? This has always worked fine for me publishing composite locators from ArcMap to ArcGIS Server.

Thanks very much in advance.

 

0 Kudos
6 Replies
JoeBorgione
MVP Esteemed Contributor

There have been other posts regarding published geocode services at 10.7.x Enterprise, and I wonder if this may be corrected at 10.8.  @BradNiemand ?

can't wait to retire....
0 Kudos
JayantaPoddar
MVP Esteemed Contributor

While configuring the Search Widget in WAB, is the custom Geocode Service above the ArcGIS World Geocoder?

Else choose your custom Geocoder from the dropdown while using the Search Widget.

JayantaPoddar_0-1622648237180.png

 

0 Kudos
MattFancher1
New Contributor III

Thanks for the reply.

I removed the ArcGIS World Geocoder from the widget config. Only my custom geocode service is included.

0 Kudos
BradNiemand
Esri Regular Contributor

The geocoding team is constantly adding features and looking for ways to improve the existing technology so newer versions of the software may function slightly different than previous versions.  The Pro 2.8 release will function very similar to its corresponding Enterprise release which is Enterprise 10.9.

The Enterprise server would need to be upgraded to 10.8.1 at a minimum or 10.9 to be similar to the Pro 2.8 version.

 

Brad

MattFancher1
New Contributor III

I found updating to 10.8.1 made no difference for the problem in my original post. I did not try 10.9.  However, I did get intersection results to return as expected at 10.7.1 by specifying either a location and search distance or a spatial extent for the search in my request. Maybe Pro does that under the hood. 

0 Kudos
BradNiemand
Esri Regular Contributor

ArcGIS Pro enables "local search" when zoomed in to a local area.  By default I believe Web App Builder does not have this setting on.  You can enable it and suggestions and geocoding will function similar to how they work in Pro.

More information can be found here:  https://doc.arcgis.com/en/web-appbuilder/create-apps/widget-search.htm 

Brad

0 Kudos