Report Attachments in ArcGIS Pro

946
7
02-15-2021 12:07 AM
Labels (1)
KyleMcDonald1
New Contributor II

Hello, 

I am creating reports using ArcGIS Pro, and including attachments. Using the same device, I have attachments appearing with the correct rotation in one project and the wrong rotation in another. Any idea why my photos would all appear sideways in the report, but not in ArcGIS Online?

Thanks

 

Kyle

0 Kudos
7 Replies
Robert_LeClair
Esri Frequent Contributor

Kyle - does this rotation issue occur in all types of browsers?  Firefox, Microsoft Edge, Chrome, Internet Explorer or just one browser?

0 Kudos
KyleMcDonald1
New Contributor II

Hi Robert, 

It's not a browser issue and in fact when viewing the photo attachments in the AGOL web map, they rotate correctly. The issue is in the Report within Pro. The output of this is a PDF report and the rotation is incorrect here.

Regards

0 Kudos
Robert_LeClair
Esri Frequent Contributor

How were the pictures collected?  

0 Kudos
KyleMcDonald1
New Contributor II

Using Collector Robert. In one project, it was fine and in the other it was an issue.

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Okay - what I'm seeing in the "internals" relates to EXIF information of the images and iOS devices.  It mentions something about images displayed in the portrait mode were actually in landscape mode hence the rotation in ArcGIS Pro.  Workaround is to open the image in Windows and save them again with the same orientation.  The analyst used http://metapicz.com to analyze the EXIF of the images and the images rotation.

Further there is a BUG-000119417 - Photos taken in the new Collector for ArcGIS (18.1.0) (iOS) app are not rotating correctly when downloaded images are viewed in ArcMap, ArcGIS Pro or other software that refers to EXIF image metadata.   I know you mentioned it works in one Project but not not another.  Might be related to what you're seeing.

0 Kudos
KyleMcDonald1
New Contributor II

Thanks Robert, I will investigate further, but worth mentioning that I was using Android on a Samsung tablet. I may run a few trials using different devices now that the guys are back from their fieldwork.

0 Kudos
Robert_LeClair
Esri Frequent Contributor

Sounds good - let me know what you discover.  In the meantime, found a related bug for Android devices.  

BUG-000089912 - Pictures taken and attached in portrait mode from Collector for ArcGIS (Android) for Samsung devices changes to landscape mode when viewed in the Collector for ArcGIS application and the ArcGIS Online map viewer.

0 Kudos