Re: Stop recreating missing geodatabases

451
6
10-14-2021 11:22 AM
AmyNewsam
New Contributor III

I'm having a similar problem - I renamed the geodatabase in File Explorer (I know, I wasn't thinking), and now no matter what I do, the geodatabase shows up as empty in Pro.  I've copied the files to a new gdb, but it also shows up as empty.  The files are there, I can see them in File Explorer, how do I make them show up in Pro?

6 Replies
KoryKramer
Esri Community Moderator

When you say you renamed the geodatabase in File Explorer, does the folder still have the .gdb at the end?

What does the folder look like in file explorer?

Examples:

KoryKramer_0-1634236912651.png

(I just tested changing .gdb to .GDB but that still reads fine in Pro)

So what do you see in the Catalog pane/view in Pro?

KoryKramer_1-1634236992309.png

Have you refreshed?

AmyNewsam
New Contributor III

Yes, it has the .gdb extension, and yes I've refreshed.

0 Kudos
RandyCasey
New Contributor III

In the past, I have had trouble with file geodatabases not working correctly if the were missing two files:

gdb

timestamps

I have had luck with copying these files into the non-functioning fgdb from a fgdb that I created as new. Not sure if this is your issue, but I thought I would pass this along just in case.

AmyNewsam
New Contributor III

the timestamp files are still in the folder.

0 Kudos
AmyNewsam
New Contributor III

I've got a ticket in with customer support now.  Will update when we get it figured out.

0 Kudos
AmyNewsam
New Contributor III

Looks like the gdb was somehow corrupted.  Thanks to all who tried to help.  🙂