Pro database connections (2), (3), etc.

87
2
Jump to solution
08-18-2020 07:20 AM
JayJohnsonWashoeCounty
Regular Contributor

Why do my database connections in the Pro Catalog Pane sometimes end up with a number appended, like (2) or (3), in the connection name?  

This suggests I already have such a connection (SOMEWHERE), but I don't see it.  How do I manage my database connections to get rid of these duplicates?

Jay
Washoe County GIS
Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
NikolasDingus
Esri Contributor

Hi Jay, if you hover over the name of the connection in the Catalog pane and see the location like in the screenshot below and navigate to it in File Explorer, do you see multiple .sde files there? The Pro project will read .sde files that are in the project folder, so if you made a connection to a database previously and then removed it, the original database connection file will still be in the project location; any new connections will then be (1) and so on.

View solution in original post

2 Replies
NikolasDingus
Esri Contributor

Hi Jay, if you hover over the name of the connection in the Catalog pane and see the location like in the screenshot below and navigate to it in File Explorer, do you see multiple .sde files there? The Pro project will read .sde files that are in the project folder, so if you made a connection to a database previously and then removed it, the original database connection file will still be in the project location; any new connections will then be (1) and so on.

View solution in original post

JayJohnsonWashoeCounty
Regular Contributor

Yep, that was exactly what I needed - thanks Nikolas!

Jay
Washoe County GIS
Reply
0 Kudos