Pro Catalog View data management

154
3
09-30-2019 12:11 PM
RonaldVanderpool
Occasional Contributor

Greetings,

In Pro 2.4.1; Catalog View/feature/design/fields - I cannot move the field to a new location in the database structure. The features are all within datasets, within a blank file geodatabase with domains.

I can add these exact same blank features to a project map, open the attribute table, click the data tab/fields and move the field to the desired place in the data structure. They stay in place and I can publish with the desired format, no issues.

My issue is that every time I want to use the blank FGDB to make a new project I have to move those fields.

The question; why does the catalog view not allow me to do the field manipulation without having to add to a map every time? Am I doing something wrong? is this a catalog view bug?

Tags (1)
0 Kudos
3 Replies
KoryKramer
Community Moderator

I'm not sure I completely understand what the issue is, but it sounds like you're talking about the difference between changing field order in a LAYER vs. changing field order in the DATA SOURCE.

If you change the order in the layer, yes, that is only persisted in the layer, which is part of a map.  If you want the field order to be maintained regardless of the layer, change the order of the data source itself.

Is this getting at what you're describing?

0 Kudos
RonaldVanderpool
Occasional Contributor

Yes, that is exactly what the issue is. 

It doesn't matter if I am in the Catalog view or pane, when I select Design/Fields for any feature class and the above image is the reference, I cannot change the order of the fields. I get a slashed circle when attempting to drag field to the new position. Above the fields were added at a later date than feature class creation and it would be nice to have the PIPE_CLASS & PRESSURE_CLASS right under the PIPE_SIZE. This is really only a convenience matter most specifically so in Collector the field workers do not have to scroll to the field and I do not have to rearrange in the pop-up. I typically fix as I develop a new geodatabase (copy) from an existing blank geodatabase by just opening each copied layer and moving the fields before I populate the feature class. Would like to just fix the blank geodatabase instead of recreation or having to do what I describe above.

0 Kudos
RonaldVanderpool
Occasional Contributor

Greetings Kory.

Any update information?

0 Kudos