PRO 2.5.1 - Model fails to run if scheduled

579
1
01-26-2021 05:09 AM
PanGIS
by
Regular Contributor

EDIT: got confused with versions. it's 2.5.1

 

Hi!

First time that I try a scheduled model.

 

I created a simple model that is supposed to import data from a csv every 15 minutes.

csv is in a local folder -----> to Enterprise GeoDB

 

The model works both on editing mode or as a tool but fails as soon as I put it on schedule.

I keep PRO open and I am connected to the Enterpise GDB when I tested.

 

Also, I tested a simple tool that import in a file GDB and it worked.

 

Any idea?

Thanks!

1 Reply
AntivenomDev
New Contributor

I had this same issue.  When I ran the model from ArcPro interface, it ran successfully every time.  When I ran it from the schedule, it failed.  Two things worth noting:

1. The model had been running successfully from a schedule and then something changed and it started to fail.  Perhaps, I upgraded my version of ArcPro.  

2. It was giving me an ERROR 000732 Input Features does not exist or is not supported.  The features that it was referring to is a publicly shared feature service.  There are other feature services that are accessed in the model without problem.  

Things that I did to fix the problem. 

1. Made sure that my default python path was pointed to the arcgis pro installation.  Good instructions here: https://superuser.com/questions/1399544/how-to-change-default-python-executable-on-windows-10/139954...

2. For some reason, the variable names in my model were problematic.  I walked through the model making sure that each variable name had a unique name and that the correct variables were input features to the correct geoprocessing tasks.  

After completing these two tasks, the schedule runs again.  I'm not sure which one of these resolved to the problem, but hopefully it can help somebody else.