Pro 2.0 crashing when changing layer symbology

933
2
07-21-2017 06:37 AM
TomDeBaun1
New Contributor

As the title states ArcGIS Pro 2.0 sometimes crashes when I try to change a layer's symbology. In most cases it crashes my graphics driver and I have to close and reopen the map I am working on to continue, although sometimes Pro itself crashes or freezes completely. In the prompts I get it suggests updating my graphics drivers, tho I have done this and it does not seem to have made a difference. These issues happen regardless of whether or not the data I am working with is hosted locally on my computer or on ArcGIS Online. I also sometimes have this issue occur when trying to add or edit labels, although it is not as frequent. It seems that this happens more often with polygons and points, I don't tend to have issues with lines but currently I am not working with many line shapefiles. This problem does not seem to be particularly common so is it possible that it is a hardware issue? I'm not really sure what else it could be. For reference I am working on an HP Probook 450 G2, with an extra RAM chip installed (giving me 16 GB instead of the stock 8), but no other modifications. I believe with this computer since there is no dedicated GPU it is done by the processor, which is a hyper-threaded dual core so I think that's where the issue lies but I'm really not sure.

0 Kudos
2 Replies
Salmon_ArmBC
New Contributor III

Hey! I also had this problem. We switched to the OpenGL rendering engine and now it's working smoothly. Options>Display and then select OpenGL as the rendering engine. Let me know if it works. This was so frustrating for me!

AhsanulKabir
New Contributor

Thanks Salmon.

In 2021 the same helps

0 Kudos