Parameter Dependency non-functional in ARCPRO model builder?

355
3
11-06-2020 11:00 PM
AaronKing3
New Contributor II

I am trying to do the exact thing that the Help page, here:

Model parameters—ArcGIS Pro | Documentation 

says:

Dependency

You can make one parameter dependent on another parameter. The most typical use for this is to make one parameter that accepts an attribute field dependent on another parameter that is a feature class or table; the field parameter will present a drop-down list of attribute fields from the dependent parameter.

But when i open up the model properties to look at my parameters, and click on the "Dependency" cell for any parameter, nothing happens. I can set filters on Parameters, but I cannot set one to be dependent on another. 

Pretty desperate to get this to work. I need to be able to select the field from the set of fields in the relevant FC - exactly the application that the help page mentions. 

3 Replies
DanPatterson
MVP Esteemed Contributor

Does your model have the required input designated with a P as shown in the link you provided?


... sort of retired...
0 Kudos
AaronKing3
New Contributor II

Absolutely. As I said, I opened the Model Properties, and examined the Parameters, where I tried to use the Dependency function. I am clicking on the Dependency column in the Parameters window of the Model properties. By definition, I can only see Parameters in that window. 

All it does is turn the cell blue, and it has no function whatsoever. Nothing happens. Nothing continues to happen when i right-click. I also tried clicking the index of the "Field" parameter shown below (index value = 1) and dragging it to the Dependency box of the index 0 Parameter, and I tried the reverse of that. When I do that, it can reorder the Parameters so that the "Field" Parameter becomes Index 0, but otherwise, nothing happens. 

In all cases, I have then clicked OK, closed the model after saving, and then tried to run it from the toolbox to see if the Dependency has taken effect. It has not. The "Field" Parameter does not have a drop-down list of any kind, let alone one that is filtered by the Fields available in the Feature Class occupying the "Candidate Factors" Parameter.

I am using an Advanced license. I have full access to every function in ARCPRO. I am running 2.6.2 and it says my version is current.

I really need this to work. Is the functionality simply not implemented? 

0 Kudos
TI
by
Occasional Contributor

Did you ever have any luck with this?  I'm having a similar problem.  In my case, there is a dependency there, but it's wrong, and I want to change it, but clicking on it does nothing.

0 Kudos