Output from Share->Map gives wrong area

114
3
08-15-2019 03:15 PM
Highlighted
New Contributor

When exporting a map view using Share->Export->Map, the output does not match the current view extent. This was an issue in older versions that was supposedly fixed in 2.3 (https://community.esri.com/ideas/15804-printing-from-arcgis-pro), but I am still seeing the issue in 2.4.1. Exporting layouts works fine, but doesn't allow generation of world files or GeoTiff tags. The selected export resolution doesn't seem to change the output area. I use 4K resolution, but switching to lower display resolution doesn't fix the problem either. Is there anything else I can do?

In another attempt to resolve the issue I set a custom extent for the map, and clipped the map to the same extent - I would assume that the output image in such a case would be limited to that clipped extent, but it is not. So neither the custom map extent nor the current view window control the output image extent. The output view seems to be hardwired somehow.

Reply
0 Kudos
3 Replies
Highlighted
by
Regular Contributor

I can't remember a single Pro version where the screenshot export worked properly. My usual workaround is exporting a larger area and then clipping it.

Reply
0 Kudos
Highlighted
New Contributor

Yeah, that's pretty much the only solution at the moment, but when I do that (as I have to) I have line work and labels that end of being reproduced at a much larger scale and with less detail than they should.

Reply
0 Kudos
Highlighted
by
Regular Contributor

You have to keep the scale constant. For example if I want to export a map at 1080p I switch the monitor resolution to 4k and then export. Since the scale stays the same, nothing should change style-wise. See here: Imgur: The magic of the Internet 

Check if your card allows setting a custom resolution (e.g. NVIDIA control panel).

Reply
0 Kudos