New Projects Connect to Another Project's Database by Default

295
5
Jump to solution
07-08-2021 11:25 AM
Labels (1)
DanielMiranda1
New Contributor II

When creating a new project without a default template, in addition to a new default geodatabase being created, the projects are always connected to a second unrelated database that I have to remove.

The default option is set to create a new database, but I cannot figure out why it is connecting to this second database whenever I create a new project. It is always this UtilityData.gdb.

See below:

DanielMiranda1_0-1625768636525.png

Is there any way to prevent the connection?

0 Kudos
1 Solution

Accepted Solutions
jcarlson
MVP Notable Contributor

In the Catalog Pane, go to Favorites. Items in the favorites list have the option of being added to all new projects. Make sure that option is turned off for the UtilityData.gdb item.

If that database is not listed in your favorites, then it's something I haven't seen before.

- Josh Carlson
Kendall County GIS

View solution in original post

0 Kudos
5 Replies
ABishop
Regular Contributor III

@DanielMiranda1 

You can change this in the options in ArcGIS Pro.  In your Pro project, click on the Project tab then click on "Options" in the left-hand panel.  Inside of the options, click on "Current Settings" this will enable you to set a new default database for each new project.  Hope this helps.

Amanda Bishop, GISP
0 Kudos
jcarlson
MVP Notable Contributor

In the Catalog Pane, go to Favorites. Items in the favorites list have the option of being added to all new projects. Make sure that option is turned off for the UtilityData.gdb item.

If that database is not listed in your favorites, then it's something I haven't seen before.

- Josh Carlson
Kendall County GIS
0 Kudos
DanielMiranda1
New Contributor II

That database was selected as a favorite. Once removed, it no longer connected by default. I must have made that database a favorite at some point without realizing. At least I now know what favoriting a database does.

 

Thanks!

0 Kudos
ABishop
Regular Contributor III

@jcarlson and @DanielMiranda1 

I have done what jcarlson is suggesting and it still appeared again in my database connections and favorites list.  You may have to go into the favorites.json file in your profile and remove that connection using a text editor and saving the json file again.  As an example, I can find mine here: C:\Users\abishop\AppData\Roaming\Esri\ArcGISPro\Favorites\favorites.json

Amanda Bishop, GISP
0 Kudos
ABishop
Regular Contributor III

My apologies @jcarlson  - this must be new in ArcGIS Pro, because I did uncheck the "Add to New Projects" option under the favorites tab and it remove that from my favorites.  Thanks for the tip!

Amanda Bishop, GISP
0 Kudos