My annotations are displayed under my data...

565
7
10-24-2023 09:18 AM
Zazie-CASIMIR-FAVROT
New Contributor II

Hello,

I'm sorry for the wording, I'm French 😅

I converted my " labels " to " annotations " so I could move them because the " labels " were displaying poorly and my map was unreadable.

Now I can move the " annotations ", it's better! However, they are displayed below the data on the map, and that's not cool... However, in the " content " panel, in the " drawing order " list, they are right above the data. But the data is displayed on top of the map, on the " annotations ", so the annotations are unreadable in places...

Do you have a solution for this?

Thank you so much !

0 Kudos
7 Replies
SLouq
by MVP Regular Contributor
MVP Regular Contributor

If you converted labels to annotation, then you can move them where you want. If they are displaying over you data then just move them off your data. 

0 Kudos
Zazie-CASIMIR-FAVROT
New Contributor II
 

Indeed, thanks to the "move" button, I can move them on the map, from left to right, to place them where I want, but they are always under the data... how can I move them above the data like you say so? Thanks !

0 Kudos
SLouq
by MVP Regular Contributor
MVP Regular Contributor

I know in ArcMap you could go to the drawing toolbar and access annotation settings there to move to front and move to back and such. Pro doesn't have a drawing toolbar but if I had access to those settings in ArcMap, then Pro must have something similar to the drawing toolbar which allows the same functionality. 

I hope this helps. 

0 Kudos
Zazie-CASIMIR-FAVROT
New Contributor II
Indeed I remember having already done it on ArcMap... but in ArcGIS Pro, I can't find this option... I explored all the buttons, especially in the editing toolbar, but I can't find what I want... =( Thank you for your help anyway ! 😃
0 Kudos
Zazie-CASIMIR-FAVROT
New Contributor II

Maybe I have an idea of the problem... On my map, I have proportional circles that I made from a surface layer.
So, it's the same behavior as for labels (still on top of the map). There is therefore a conflict with the annotations made from the labels : the circles will always be displayed on top...

0 Kudos
SLouq
by MVP Regular Contributor
MVP Regular Contributor

Just in case cause this has happened to me already. It could be as simple as moving your annotation layer up in the table of contents, so it is above all the other layers in your map. 

0 Kudos
Olivier_B
New Contributor

Hello Zazie, 

Dans la symbologie de ta couche proportionnelle, décoche "Dessins proportionnel toujours au dessus des autres couches". J'ai mis quelques heures à trouver ce paramétrage. 

In symbology tab of your proportionnal layer, uncheck "Draw proportionnal symbols above all layers". 

annotation.jpg