ModelBuilder won't change sources

09-20-2021 12:42 PM
Labels (1)
New Contributor

I built a model in ArcGIS Pro 2.8.2 that I need to share with a co-worker. It works great in the development test project. However, when I move it to a new project it won't update the relative paths to the new default database and is stuck on the original dataset. I've tried manually resetting each process and also tried using %scratchgdb% but no luck.  I also installed the 2.8.3 patch but didn't see a change in behavior.  A sample of the toolbox is attached.

0 Kudos
2 Replies
Regular Contributor

Sounds like you should rather use the in_memory workspace. Using the in-memory workspace is also usually significantly faster and really easy to use. 

To write to the in-memory workspace, specify an output dataset path beginning with
in_memory, for example, in_memory/outputReserves. In this example the outputReserves is a temporary name. 

Frequent Contributor III

Don't use relative paths, use absolute paths

0 Kudos