Minor annoying Problem in Pro publishing to server

459
7
Jump to solution
07-02-2019 10:45 AM
Highlighted
MVP Frequent Contributor

I'm so happy that https://community.esri.com/ideas/12258-arcgis-pro-publish-services-to-arcgis-server is fully implemented I'm probably not going to log a case on this, but this is somewhat annoying. When publish to any of my servers that have the letter "D" in the web adapter name, the URL of the service returned to Pro is wrong. These are all 10.6.1 unfederated servers. This makes "Manage the Map Service" at the end of publishing somewhat difficult. 

Note the "d" missing:

missing "md" here: 


Same in SharingInfo.json

Is anyone else seeing this? Were you able to figure out an easy fix? Wondering if it's related to how I'm naming my server connection?

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Contributor

Hi Thomas, 

I am able to reproduce the issue and we are looking into it. It seems to occur when you include 'admin' at the end of your server URL in the dialog where you made the server connection. As a workaround, make a new server connection, entering your server URL as "https://server.domain.com/webadaptor' without 'admin'.  

Thanks. 

View solution in original post

7 Replies
Highlighted
Frequent Contributor II

shouldn't your address include a :6443 or some such in the address.  and should you be publishing to your Rest services directly.  We have our not visible. 

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

We have CA-signed certs on both the server and the webadapter, so adding the port is not required. Not clear about publishing rest services directly? Is there another way to publish services? We control access to the rest endpoints with Active Directory. 

Reply
0 Kudos
Highlighted
Frequent Contributor II

We don't have our rest visible.  when we publish from pro or arcmap we publish to a string similar to this

https://maps.mycompany.com:6443/arcgis

the rds is the other option.

Our rest is hidden.  Though it really should not make a difference. 

This is odd. I asked couple other guys here. We have dozens of services spun up with D's in them 

Reply
0 Kudos
Highlighted
MVP Frequent Contributor

ahhh. I have quite a few GIS servers, so it's something like

https://maps.mycompany.com/server1

https://maps.mycompany.com/server2

https://maps.mycompany.com/server....

https://maps.mycompany.com/server10

Reply
0 Kudos
Highlighted
Frequent Contributor II

it looks like your publishing from Pro.

Have you tried going into managing your portals and logging in to the portal using a normal log in and not the rest. 

though you really got me, it should not be truncating the d

my log into our portal used in the example is simply 

https://maps.mycompany.com/arcgis 

good luck 

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Thomas, 

I am able to reproduce the issue and we are looking into it. It seems to occur when you include 'admin' at the end of your server URL in the dialog where you made the server connection. As a workaround, make a new server connection, entering your server URL as "https://server.domain.com/webadaptor' without 'admin'.  

Thanks. 

View solution in original post

Highlighted
MVP Frequent Contributor

Unfortunately, when using right-click -> properties to convert a sever connection to "Publisher" (introduced in 2.3) for the purpose of publishing services, "admin" is what you get. As said, this is a minor annoyance and in no way blocks any critical functionality, glad you could repro it.