Merging features - missing some constituent attributes

798
3
06-04-2022 02:23 PM
RichardMorris
New Contributor III

Hi - I wish to merge three feature layers along with their attributes. I've tried doing this with Merge (Geoprocessing), as per the attached image. It's nearly working. However, only some of the required Attribute values are coming across (i.e. the AE4 values don't transfer).

Anything I need to aware of here?

Note - AE4 are more complex 'ribbon' polygons; AE2 and AE1 are simple rectilinear polygons. 

Thanks

Richard

 

0 Kudos
3 Replies
DanPatterson
MVP Esteemed Contributor

Merge Layers (Standard Feature Analysis)—ArcGIS Pro | Documentation

are they of the same feature type (polygonzm) ?

or are the ones that won't merge multipart polygons? (you could try MultiPartToSinglePart tool first prior to merge)


... sort of retired...
RichardMorris
New Contributor III

Hi Dan

Thanks for your help. I didn't know what a Polygon ZM was, looking that up I understand its a polygon with Z-axis values. So I went back into properties and changed the properties 3 constituent feature layers to have zero elevation. THis seems to have worked as all the polygons are now merging. I'm puzzled because in the merged layer's Attribute Table, it calls out the new polygons as Polygon ZM... 

Although my issue is resolved (with thanks) I'd appreciate if you could explain what I'm seeing here (please see attached)

Cheers

Richard 

0 Kudos
vg11
by
New Contributor III

I was having this same issue but once I changed the save location of the output dataset, it worked. It had chosen a random gdb but I picked my most used gdb for this map and all my features transferred. 

0 Kudos