map scene package fail: layer type not supported Error 002781

209
4
01-03-2022 01:09 AM
TayLee
by
New Contributor II

I am trying to create map scene package, by loading the map from MMPK, then converting it into a global scene. The map data are of vector type

When running the geoprocessing tool to create map scene package, errors are generated for a lot of layers:

ERROR 002781: Layer type is not supported for <layer name> in runtime

Can't find info on this error, any advice TIA!

 

0 Kudos
4 Replies
Andrew--Johnson
Esri Contributor

Hi,

I'm not sure which layers are causing the error but if the error is being thrown then those layers need to be removed from the scene as Runtime does not support those layer types.

There's a short list documented here of more commonly used layers which may not capture every possible unsupported layer type

https://pro.arcgis.com/en/pro-app/latest/help/mapping/map-authoring/2d-and-3d-operational-layers.htm...

thanks,

Andrew

0 Kudos
TayLee
by
New Contributor II

It seems that map scene package does not support group layers -

After I remove all layers from group layer and deleted those group layers, the map scene package finally did get generated successfully. This results in a flat layers hierarchy - which isn't a good way to organize things. Thought this is weird that ArcGIS doesn't support grouping layers in scene package? 

0 Kudos
Andrew--Johnson
Esri Contributor

Hi,

Group layers are supported in mobile scene packages so it must be one of the layers within the group layer that is unsupported. The tool will tell you which layer is not supported and needs to be removed from the scene.

thanks,

Andrew

0 Kudos
TayLee
by
New Contributor II

Thanks Andrew for the note on group layer - I went to retry by removing and re-adding the group layers for each and every grouping that the geoprocessing tool complained with errors. For some layers, the map scene package did get generated successfully (but the rendering of the layers on the Android phone is weird). And for other layers it still failed.

Anyways, I found another way to generate the package for arcgis runtime android - which is by creating vector tile package for the original data I had, and this works for both 2D and 3D

0 Kudos