locked legend items

2716
36
02-10-2020 02:55 PM
Highlighted
New Contributor III

I have a ArcGIS Pro 2.5 map in which legend items (group layer name, layer name, etc.) are locked. They are checked but grayed out. See attached snips.

I have tried deleting the legend and creating a new one. I have tried creating a new layout. I have tried removing layers and re-importing them from the database. I have re-started the application. None of these has solved the issue.

Tags (2)
36 Replies
Highlighted
New Contributor III

I just opened another project, and it has the same issue. Could this be a ArcGIS Pro 2.5 issue?

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Dan, 

In the table of contents, for the layout can you toggle on/off and have it reflected in the Legend Properties?

The only difference I noticed in you images was that it said [multiple items] which makes me think that "whatever" .. has to do with the fact that something is applying to multiple items.  Is this a complex legend?  Just a project from 2.4 or prior?  I would check within the table of contents and see if the participating featureclass layers have something applied to them

Reply
0 Kudos
Highlighted
New Contributor III

1. The legend is not locked, as shown in the 'Legend_properties" attachment.

2. The panel always says [multiple items] because there are multiple items in the legend. I don't think that the meaning of 'items' here is the same as the meaning of 'Legend Items' in the panel tab.

3. The first project I had issues with was from ArcGIS Pro 2.4. The second may have been older; I had not opened it in a while.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Legend Properties properties never shows multiple items no matter what I throw at it ... single layers, group layers etc.

All data stored locally. Pro 2.5

Reply
0 Kudos
Highlighted
New Contributor III

Unless I have no features in the Legend at all, it always says [multiple items] for me. Not all of my features are local, some are on the Internet and some are on ArcGIS Online. I also have group layers.

I discovered something else. I opened a project created in Pro 2.4 (or earlier), and the Legend worked OK. Until I saved the project, then it did not work anymore. So I'm pretty sure this is a 2.5 bug, but I'm not sure what conditions trigger it.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Dan(s), 

The "grayed out" layer name property in the first screenshot provided in the initial post indicates that the property is not the same for all the selected legend items. There is nothing "locked". You can still work with the property. Please see Work with a legend item—Layouts | Documentation for more information on working with legend items.

Here is an example.  In this layout I have a legend with 3 items, Capital, River and States by Region. Note that the layer name is positioned to the left of the symbol for Capital and River, while the layer name States by Region is above the symbols.

When I click the "Show properties..." button in the Element (Legend) pane the Element pane switches to the "[multiple items]" pane. Note that all the legend items are select in the Contents Pane (left side of the screenshot).

The "gray" box next to Layer name" indicates that the layer name for all the selected elements do not share the same properties. Some could be visible, while others are not. Or, as in this case, the positioning of the text name text is not consistent for all selected items.

If you toggle the check box you can turn off the visibility of the layer name for all items as seen below.  

If you toggle the checkbox once again you will see the layer name for all the selected items appear in the same relative position.

If you wish to change properties for a single (or a sub set) of legend items select the item(s) you want to work with from the Contents pane as shown in this example. Here I turned off Layer name and rearrange the label and patch order.

These property changes ONLY affect the selected legend items. If I select ALL the legend items again, after turning Capital layer name off, I see that I get the "gray box" next to layer name indicating a property "mismatch" amonth the selected items. Layer name for Capital item is off, while the layer name for the other elements is on.

Hope this helps, 

Tom

Highlighted
New Contributor III

Thank you, but doesn't solve my issue. If I create a brand new legend, all features are in the legend, and when I look at properties, the Group Layer name level is greyed out, though I haven't made any modifications to any feature label. Nothing I do to that legend, except remove every single feature, brings the group layer name back to unlocked. So the issue is not that I've set different properties.

I've attached a screen snip. On the right is the properties panel with Group Layer name greyed out. On the left is a portion of the Legend layers, all are selected, even those not visible, and those that are off the screen. Below are the features, showing the students group layer as turned on. The Legend showing on the map has these layers properly ordered (I've changed the order but nothing else). But the group layer name is on, and I don't want it to be, and I can't turn it off because the group layer name box is greyed out.

I know that this is different behavior from Pro 2.4, see my comment above that a 2.4 project worked correctly until I saved it, then it did not.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Dan, 

If you've attached a new screenshot as opposed to the 2 provided in the original post, they do not seem to be available. However, I believe your issue is that you want to turn the visibility of the Group Layer Name (students group layer) and do not know how to do this. Group layer name support is a recent addition to Pro - see  

Unfortunately, you have run into a known usability issue.

This is a bit tricky because the legend list is flat, while the layer list in the map can be nested with group layers and groups within groups. This allows you to split group layer items within a legend.

The visibility of the Group Layer Name item is controlled by the top-most member of the group that is present in the legend. For example, if I have group USA with layers City, Road and State. City is the top-most member of the group and its legend item controls the visibility of the Group layer name.

Toggle visibility off.

If you select either of the legend elements belonging to the group you will not be able to toggle the visibility of the Group layer name. 

In order to successfully toggle the visibility of the the Group layer name the top-most member layer of the group needs to be in the legend and this item needs to be listed above all the other elements of the group. If the top-most sub-layer is not the top-most legend item toggling the visibility does not work. This is a bug.

If you don't want the top-most layer to appear in the legend you can toggle its visibility in the Contents pane.

We are aware that this is not a good user experience and hope to improve this in a future release.

 

Tom

Highlighted
New Contributor III

Thank you. It doesn't work exactly this way for me, perhaps because there are features above the group in Map list.

I did figure out a work-around. I create a new legend and format it the way I want, then remove every item from the legend list, so that I can click off the Group Layer name item in properties, then add back in the items I need by dragging from the map list.