Layer drawing issues in Layout

156
5
03-09-2020 10:40 AM
KatieErickson
New Contributor III

When viewing the layout, some layers are not drawing. They will draw or disappear depending on the level of zoom on the page (not the map scale, just scrolling in and out of the page itself). If I export the map and a layer isn't showing it will not be in the pdf. See photos for example, when viewing the whole page, none of the layers are showing, then when I zoom into the page, they all appear.

At first I thought this was because I was working with large page sizes, however, today I am working with letter size and the same issue is occurring.

I am using the Pro 2.5, everything is up to date. It seemed to start with the latest update.@

Reply
0 Kudos
5 Replies
Robert_LeClair
Esri Frequent Contributor

Are there scale dependencies applied to the layer in question in the Contents Pane?  This would cause this behavior.

Reply
0 Kudos
KatieErickson
New Contributor III

no, I am not changing the scale at all, it is when I zoom in/out of the layout page itself. It does not seem to be a particular layer. I have contacted Esri and am working with someone on it.

TomBole
Esri Regular Contributor

Katie, 

Have you tried clearing the local cache?

From the help Set display options—Properties of maps | Documentation :

To troubleshoot rendering issues, or otherwise free up disk space, you can delete the entire cache by checking Clear cache. The cache will be deleted once you click OK to close the Options dialog box, and the project will close and reopen. You can remove the visualization cache for a specific layer using the layer's cache properties; the existing cache for other layers will not be removed.

You can request a redraw of the view by pressing the F5 key. This will draw from the cache and not invalidate it. You can also request a full refresh of the drawing cache (invalidating it rather than deleting it) by pressing Ctrl+F5.

This might help.

Tom

Reply
0 Kudos
KatieErickson
New Contributor III

Thanks Tom. I will try it out. Does this clear the cache from Pro in general or is it just for that specific project? Curious because this has been happening to multiple projects.

Reply
0 Kudos
TomBole
Esri Regular Contributor

Katie,

The cache is project specific, though you can set cache properties for layers. I'm not even 100% sure that this will solve your problem, though it is worth a try. If you are still seeing a problem after clearing your cache this may be a bug and something that Tech support can help you with.

Tom

Reply
0 Kudos