Is there any way to stop ArcGIS Pro from assuming a Revit file units are meters when in fact they are decimal feet?

768
3
07-11-2019 01:53 PM
mrmark
by
Occasional Contributor

My scenes and maps are state plane US Feet. My Revit (2019) models are US Feet. When I pull them into ArcGIS Pro the models are 1/3 size, and 1/3 of the way from the origin to where they are supposed to go. 

Finally discovered that if I change my Revit model units to fractional feet and inches then ArcGIS Pro renders them full size and in the correct location.* I can't find a setting anyplace in ArcGIS Pro to change this behavior. As the GIS guy, I don't have ability to change the units.

Bonus question: 
* Same State Plane US Feet scene, even when Revit layers are recognized as feet and are the correct scale and location, every layer still defaults to "meters" as the elevation unit, so I've got 6 foot tall drinking fountains and 32+ foot stories. It is easily changed in the Properties|Elevation, but if anyone know how to tell ArcGIS Pro to use the same units for Z as it is using X & Y that would be great (particularly because it is every layer, even those coming from the same file that I've already changed Elevation units to US Feet.

Tags (3)
0 Kudos
3 Replies
DA_BIM-GIS
Esri Contributor

Hello Mark, 

 

1/3 of the way from the origin to where they are supposed to go. This could be due that the file is not located in the right location (Basepoint is not set with the correct value – Revit side) For the models are 1/3 size I will need some additional information from you to be able to help you with this issue.

Finally discovered that if I change my Revit model units to fractional feet and inches then ArcGIS Pro renders them full size and in the correct location. If your Revit file is set

If the Revit file was created using imperial units, the projection should use FEET or U.S. FEET. If the Revit is using metric units (meters, centimeters, mm…) the projection should use METER as the unit.

 

 

Bonus question: 
* Same State Plane US Feet scene, even when Revit layers are recognized as feet and are the correct scale and location, 
every layer still defaults to "meters" as the elevation unit, so I've got 6 foot tall drinking fountains and 32+ foot stories. It is easily changed in the Properties|Elevation, but if anyone know how to tell ArcGIS Pro to use the same units for Z as it is using X & Y that would be great (particularly because it is every layer, even those coming from the same file that I've already changed Elevation units to US Feet.

This only occurs when the file is being georeference. After the RVT is georeference (file has a .PRJ and./or .WLD3) this is not an issue anymore.

0 Kudos
mrmark
by
Occasional Contributor

Thanks for your reply David.  Unfortunately the issue persists. Addressing your first two responses

This could be due that the file is not located in the right location (Basepoint is not set with the correct value – Revit side) 

The Revit files are located correctly, with both the basepoint and survey point using US Feet. 

If the Revit file was created using imperial units, the projection should use FEET or U.S. FEET. If the Revit is using metric units (meters, centimeters, mm…) the projection should use METER as the unit.

This is exactly my point. My Revit models are using Imperial units, the projection is using US Feet, and all my data shows up exactly where it should when Revit is set to use Feet and Fractional Inches. If the units are set to Decimal Feet with NO other change to the Revit file or the ArcGIS project, suddenly the models are 1/3 their size and 1/3 of the way from the origin to where they should be. Changing it back to Feet and Fractional Inches results in the model showing up where and how it should. 

 This only occurs when the file is being georeference. After the RVT is georeference (file has a .PRJ and./or .WLD3) this is not an issue anymore.

This is sort of true. I have a .PRJ file in the folders with the REVIT models, and as I mentioned, they are showing up where they should, and XY size is appropriate, but 3x as tall as they should be. It isn't enough to have the horizontal projection parameters in the .PRJ, it must also have vertical coordinate system defined that uses US feet. 

ArcGIS Pro 2.4, Revit 2019

0 Kudos
JoeBryant1
Occasional Contributor III

March 2022: ArcGIS Pro 2.8, Civil 3D 2020

Any update on this?

I'm seeing the same behavior in Pro when importing a DWG to a fresh, empty Scene. The coordinate system in C3D was defined (NAD83 HARN SP CA ZnIII US_ft), but Pro did not recognize this coordinate system. I had to define the projection for one of MANY layers brought in from the DWG, but luckily all the other layers updated in sync to the correct XY location after defining the first one.

However, the elevation units do not update automatically. I know that the z-values are in US survey feet referenced to NAVD88. I just recently learned that vertical datums cannot be defined in a Civil 3D 2020 DWG - you have to get this info from the engineer or surveyor. The z values are unitless. All of the MANY CAD layers have their elevations units defaulted to meters in ArcGIS Pro 2.8. I'm guessing this is because Pro adds the default base ground elevation surface to new scenes which is in meters (WGS84), and undefined layers get the scene coordinate system applied.

Now I have to manually change the elevation units property for each of the MANY DWG layers from meters to US_Feet.

There has got to be a better way, right? Either a setting in C3D, or a different import process? Maybe create the scene first and update the scene elevation unit properties to US_feet first before importing the DWG? Or maybe there is a way to bulk update the elevation units for all the layers in a scene?

0 Kudos