How to reverse transparency masking in Pro?

557
3
12-18-2019 07:47 AM
ThomasColson
MVP Frequent Contributor

Following Use Feathering to Accentuate the Area of Interest in Your Map , I have a feature class with attributes like this. What I did was follow Use Feathering to Accentuate the Area of Interest in Your Map , then add "ZPAR" with the values in the opposite order: 

   

Because what I want is the opposite of Use Feathering to Accentuate the Area of Interest in Your Map , I want the INNER ring to be 100% transparent, and the OUTER ring to be 100% solid.

No Matter what I do here:

Or here

I always get, 100% of the time, a feathered ring mask where the outer ring is transparent and the inner solid, opposite of what I need. I have used every single setting in the Transparency Settings in Pro, and used every field, and tried every combination of every single button and number I can type in, been at this for days, always the same result. Is there a bug in Pro regarding transparency, or is there another hidden button I'm missing?

Tags (2)
0 Kudos
3 Replies
ThomasColson
MVP Frequent Contributor

And......the problem was the Dissolve Option. I'm used to Arc Map, where I always picked "All", and in Pro, I thought Overlapping was the equivalent. So running this in Python

arcpy.analysis.MultipleRingBuffer("BOUNDMASK", r"C:\PROJECTS\PRO_JUNK_GEODATABASE.gdb\MULTI_RING", [5,10,15,20,25,30,35,40,45,50,55,60,65,70,75,80,85,90,95,100,105,110,115,120,125,130,135,140,145,150,155,160,165,170,175,180,185,190,195,200,205,210,215,220,225,230,235,240,245,250,255,260,265,270,275,280,285,290,295,300,305,310,315,320,325,330,335,340,345,350,355,360,365,370,375,380,385,390,395,400,405,410,415,420,425,430,435,440,445,450,455,460,465,470,475,480,485,490,495,500], "Meters", "distance", "ALL", "OUTSIDE_ONLY")
<Result 'C:\\PROJECTS\\PRO_JUNK_GEODATABASE.gdb\\MULTI_RING'

And adding a larger white background resulted in this

0 Kudos
LilyCrandall-Oral
New Contributor

Hi! I'm having the same problem in Desktop, except I did select DISSOLVE ALL when I created my buffer... Any pointers? 

LilyCrandallOral_0-1625166092790.png

My statement for the Xpar attribute field was ((100 * [FromBufDst])/380) , where 380km was the greatest buffer distance. 

0 Kudos
LilyCrandall-Oral
New Contributor

I went in and manually reversed the field values in the @ table. It worked? Not sure how to adjust my statement but a workaround for sure:)

 

LilyCrandallOral_1-1625166469742.png

LilyCrandallOral_2-1625166486284.png

 

0 Kudos