How to keep Modelbuilder from adding duplicate layers after process is run

414
4
Jump to solution
08-24-2021 07:11 AM
JustinBernard1886
New Contributor III

Hi all,

When running modelbuilder, I have an issue where modelbuilder will add a duplicate layer to my map with a competely new layer name. The thing is, this layer is just a duplicate of the exisiting layer and the general name seems to be an ESRI generated name(The source and alias names remain the same). 
Is there anyway to mitigate this issue? I should add, the output is correct, and while I could simply remove the layer, it's a bit of an annoyance to have to remove the layers everytime the model is run. 
I do not have "add layer to map" checked for any of the outputs.

I am using ArcGIS Pro 2.6

Cheers,

Justin

0 Kudos
1 Solution

Accepted Solutions
JustinBernard1886
New Contributor III

Thanks for the responses. My team decided the issue is a minor inconvenience and we will just remove the extra layer from the workspace. Apologies if it sounds confusing. The model updates the input layer correctly, but then adds a duplicate of the input layer to the workspace. I was hoping to understand why, but it's not a major impediment, I'll just remove the layer.
Thanks for the responses

Justin

View solution in original post

0 Kudos
4 Replies
DuncanHornby
MVP Frequent Contributor

You do not say which software you are running: Arcpro, ArcMap or even ArcCatalog?

0 Kudos
JustinBernard1886
New Contributor III

Apologies.
ArcGIS Pro 2.6

0 Kudos
DuncanHornby
MVP Frequent Contributor

When you say "...this layer is just a duplicate of the existing layer" are you referring to the input layer or a layer generated as output of the model?

Suggest you edit your question to include a screen shot of your model.

0 Kudos
JustinBernard1886
New Contributor III

Thanks for the responses. My team decided the issue is a minor inconvenience and we will just remove the extra layer from the workspace. Apologies if it sounds confusing. The model updates the input layer correctly, but then adds a duplicate of the input layer to the workspace. I was hoping to understand why, but it's not a major impediment, I'll just remove the layer.
Thanks for the responses

Justin

0 Kudos