How to disable auto-docking of attribute tables?

1680
7
Jump to solution
02-01-2018 10:35 AM
MikeW
by
New Contributor III

Everytime I open an attribute table it automatically docks beneath the main map pane.  I like to view my attribute table in a floating window that I often place on my second monitor (as is industry/professional standard).  However, even if I un-dock the attribute table and close it, then re-open another table in the same session it still auto-docks.  How can I change this setting?  ArcMap would automatically float or dock the attribute table based on previous sessions.  Is there a docking manger like this: Creating a new docking setting—Help | ArcGIS Desktop  ?

1 Solution

Accepted Solutions
MartinDe_Las_Heras
New Contributor III

Y'all just need to check Project > Options > User Interface. See screenshot below:

ArcGIS Pro table settings

View solution in original post

7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

I haven't found a way... every table open is docked... but once you get it floating it stays floating, but there is no toggle to stop autodocking and as you have probably noticed you have to keep a firm grip on the mouse so that it doesn't drag you into an unwanted docking location.

And this is Pro 2.1 BTW.

KoryKramer
Community Moderator

This is the current design.  My understanding is that you're requesting https://community.esri.com/ideas/14052‌  

The docking manager you refer to is specific to the Production Mapping extension for ArcMap.

MikeW
by
New Contributor III

Yes, thank you.  I wish I could upvote it 10000 times.

NBruce
by
New Contributor

Me too, I really hate this feature.

0 Kudos
MartinDe_Las_Heras
New Contributor III

Y'all just need to check Project > Options > User Interface. See screenshot below:

ArcGIS Pro table settings

KoryKramer
Community Moderator

Implemented in ArcGIS Pro 2.5 along with many other user-requested features.  See https://community.esri.com/community/arcgis-ideas/blog/2020/02/06/ideas-in-arcgis-pro-25-thats-amore...

0 Kudos
VladimirStojanovic
New Contributor III

Many thanks Martin De Las Heras‌ for this info!

I tested it and it works! Very good, very well ESRI, thank you.

Cheers.