How do I Fix Arc Pro Freezing when Selecting an Annotated Feature

1382
8
Jump to solution
08-10-2021 12:12 PM
SpencerSeibel_IDFG
New Contributor II

Hi all,

I am trying to delete unnecessary annotated road labels using the Selection tool under the Edit tab. It was working just fine until recently; Arc Pro highlights the label when I click on it but does not fully select it, and I cannot delete the label or press ESC to cancel the selection attempt. This freezes all other functions besides allowing me to swap between layouts or maps. See the image below:

SpencerSeibel_IDFG_0-1628622270854.png

My usual fix for this has been to delete the annotated feature class and remake it (after closing the program with Task Manager). Unfortunately, this no longer works.

I have tried deleting the labels from both activated layouts and the source maps but it makes no difference. Restarting the computer does not fix the issue either.

Does anyone know how I can get back to deleting labels normally?
Much thanks for any help!

--Spencer

0 Kudos
1 Solution

Accepted Solutions
CraigWilliams
Esri Contributor

We've seen an issue in the past where selection would freeze if map tips were enabled for any other layers on the map. We're working on a fix for this issue, but turning map tips off will help in the meantime.

View solution in original post

8 Replies
AngelaMarsh1
Esri Contributor

Hi Spencer!

Are you able to provide some details on what version of ArcGIS Pro you are running and if its an enterprise system? Also are you creating annotations within Pro using label to annotations? Are they stored annotation layers in the database or annotations within a map? Are you importing annotations from another file type (eg CAD)?

ArcGIS Pro changed the way it stores annotations somewhere around Pro 2.0. Annotation layers stored in a database are now stored as point features rather than traditional annotation type layers. This caused issues for me in the past, as I was attempting to run FME workbenches from an older geodatabase to a new one and it was failing repeatedly. I had to convert all annotations to point features before migrating.

You can still import, view and interact annotations from older versions but they can cause issues in Pro.

Theres a tool in the toolbox called 'Upgrade Dataset' which can be used for annotation layers and it'll help get rid of any funny business based on versioning. This can only be run on annotations that are stored as annotation layers in the database, and your database has to be at the right version to support the upgrade also.

My recommendation would be to try to run that tool on all your annotation layers and see if that helps at all.

 

Let me know if any of this was helpful.

All the best!

Angela

Happy Mapping
SpencerSeibel_IDFG
New Contributor II

Hi Angela, thanks for the response.

I'm using a basic license for Arc Pro 2.7.0., and it is not an enterprise system. The annotations are generated from the original shapefile's GDB and are placed in the same host GDB, and will not be needed for cross-application use.

I found another fix today by copying the map to a different project and editing it from there. I can also try the suggested upgrade fix since it looks like 2.8.1 is the newest version of Pro.

Thank you for the help!

--Spencer

CraigWilliams
Esri Contributor

We've seen an issue in the past where selection would freeze if map tips were enabled for any other layers on the map. We're working on a fix for this issue, but turning map tips off will help in the meantime.

SpencerSeibel_IDFG
New Contributor II

Hi Craig, thanks for the heads up! None of my layers had tips enabled when the issue was happening.

As of today, my current fix is copying the map to a different project and working on it in there. I'll do this until that project starts giving me the same problems.

Thank you for the help!

 

--Spencer

JakubSisak
Regular Contributor II

Calling this a solution is incorrect. It is well know that there are rendering issues in Pro that have not yet been solved and this is one of them. This problem is not specific to annotations but all selections; anyone working in actual production editing environment experiences this all the time as the map rendering hangs all the time, specifically when making frequent selections with the  "Selecting... Press Escape to cancel." message. This is one of the reasons why myself and others when needing to perform many edits and selections still prefer to do these tasks in ArcMap which is lighting fast in comparison. 

I would like to urge the OP to uncheck this as "Solved" as it has not been solved. OPs solution of copying data to a new map and working in that map until it starts causing issues is the only workaround for this. Clearly there is a rendering or caching problem somewhere. Not even mentioning I need to re-open map all the time sometimes restart the entire project to make Pro render things on the map and none of the workarounds, solutions, suggestions, etc. provided to date in numerous forums work. 2021-10-23 10_20_50-Window.png

PegGronemeyer1
New Contributor III

I have to agree with @JakubSisak ...  this is NOT a solution.  A solution is fixing Pro so that it doesn't freeze when using a selection tool.   And I agree also on the "why we often use ArcMap instead of Pro" comment.  

After reading the posts, I also realize that the select has frozen Pro several times, but that I never had figured out _what_ had caused Pro to freeze until now.  I had thought I had done something incorrectly, couldn't resolve it, and hence, went back to ArcMap.....  No one can constantly be copying a map to a new one or rebooting Pro when using something SO basic as the select tool.  

NickalausNielsen
New Contributor

I will verify what @JakubSisak and @PegGronemeyer1 are saying. I work daily with basic functions like editing vertices and creating features for a digitization project and find myself spending more time waiting for Pro to catch up than producing actual work. For me, selecting existing polygons to edit vertices can take upwards of 5-20 minutes, especially when switching the selection from one to another. This is my main and only source of daily frustration.

My desktop experience is all on Pro and does not make a lot of sense for me to switch to an older version of ArcMap, but at this point I am not sure if I have an option moving forward. It is so hard to understand how this remains an unfixed problem at Esri. Please remove this post as SOLVED and provide a solution that does not result in me having to abandon Pro.

0 Kudos
bhmiel
by
New Contributor

I would like to repeat the statments of others in the bottom of this thread that this issue is NOT resolved.  

This appears to be the same problem that I am having:
https://community.esri.com/t5/arcgis-pro-questions/arcgis-pro-hangs-when-selecting-attributes-in-map...

0 Kudos