Hide Time value in Layout?

170
2
Jump to solution
08-31-2020 01:47 PM
Occasional Contributor

Hi all, I have a Table Frame which is showing some related records. One of the fields I need to show is date of submission, but I cannot seem to hide the Time values (Date field) in my Table Frame in my Layout view. I've disabled Time in the "Configure Attributes" setting at both the Hosted Layer and Web Map levels, but these settings don't seem to persist through when I bring the Web Map into Pro. I see the same thing using either the Table Frame or a single field as Dynamic Text, and I haven't had any luck adjusting this through the dynamic text options yet.

It wouldn't be the end of the world if they weren't showing in UTC time, so if I could fix that then that would help as well...

This is Portal 10.6 with ArcGIS Pro 2.6, so maybe I am limited by that? Thank you for any suggestions.

Reply
0 Kudos
1 Solution

Accepted Solutions
Occasional Contributor

Thank you Tom! That is helpful to know, even if the answer is it is not possible for the Table Frame (so at least we stop trying). With the field, I tried this expression and it works, except for it returns the month one number off. I found this GeoNet post which explains it is to be expected. I ended up using:

var month_fix = Month($feature.date_field) + 1
return month_fix + "/" + Day($feature.date_field) + "/" + Year($feature.date_field)

Thanks again for your help.

View solution in original post

2 Replies
Esri Regular Contributor

Hi Brittany, 

Looks like you'll need to format the Date field. There is no way that I'm aware of that you can do this in a Table Frame. I believe you would need to format the field itself, or create a new field with the date formatting you desire in order for this to work with a Table Frame.

For dynamic text you can use the following Arcade expression to display just the date portion of the Date field value - 

Month($<Date_fieldname>) + "/" + Day($Date_fieldname) + "/" + Year($Date_fieldname)

Hope this helps, 

Tom

Occasional Contributor

Thank you Tom! That is helpful to know, even if the answer is it is not possible for the Table Frame (so at least we stop trying). With the field, I tried this expression and it works, except for it returns the month one number off. I found this GeoNet post which explains it is to be expected. I ended up using:

var month_fix = Month($feature.date_field) + 1
return month_fix + "/" + Day($feature.date_field) + "/" + Year($feature.date_field)

Thanks again for your help.

View solution in original post