Georeferencing bugs in ArcGIS Pro

02-07-2019 10:45 AM
MVP Regular Contributor

Hello Geonet!

Has anyone else had issues with georeferencing images in ArcGIS Pro? It's something I do on an almost daily basis in ArcMap, and I keep attempting to switch my workflow to ArcGIS Pro to practice using the software since I know Esri is planning on transitioning completely to Pro. 

However, I find the experience to be so buggy that I can't even complete this simple task. After fitting an image to display, I try to pan around and my cursor is stuck on the rotate function, no matter which button on my mouse I click. If I change the transparency of the layer with the ribbon and then use the L keyboard shortcut to turn the layer off/on, the transparency doesn't save and it always goes back to 0%. However, if I turn the layer off/on in the TOC it seems to stick. 

The biggest offender is that when I try to set a control point, once again my cursor is stuck on the rotate function. This has happened so often that I frequently can't georeference the image at all. On my most recent attempt, after several minutes somehow it seemed to change (though I have no idea what caused that to happen) and I was able to set a few control points, but then I opened the control point table and once again the pan function didn't seem to work using either my mouse or the C keyboard shortcut. 

After enough frustration I went back to ArcMap for a completely smooth process and had several images georeferenced in less than five minutes. 

Just want to know if I'm alone in this experience or if there are others who share my frustration? I am eager to embrace ArcGIS Pro and the changes that Esri is promoting, but I can't do this if I can't even complete simple workflows such as this.

Thanks for any thoughts or input!




“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
26 Replies
Occasional Contributor

Sure.  Maybe I wasn't clear.  She wasn't producing world files.  

She was having the same georeferencing issue where it was not updating the .aux file.  She started messing with the settings mentioned in the ArcGIS 10 desktop article I posted above.  She thinks enabling the world file and disabling the world file setting fixed the issue. 

0 Kudos
Occasional Contributor

So I think we solved our georeferencing bug.  It has to do with the .sdwx file.  

If we were having issues with saving georeferencing where it would not produce an updated .sid.aux.xml file, we would export control points.  Then we would check to see if it had a .sdwx file.  If it did we would delete it.  Sometimes it would require removing the .sid from the TOC and/or rebooting ArcGIS Pro because Pro would "remember" the deleted file. 

Then we would bring the "naked" .sid file back into Pro and start georeferencing again, but this time we imported the control points.  The map popped up where it was supposed to be again.  Save georeferencing and it creates a good .sis.aux.xml file.  

So what does the .sdwx actually do?  We have been trading .sid.aux.xml files of maps we have georeferenced with each other.  We all have the .sid files.  We pair the .sid with the .sid.aux.xml in the same folder and open it with Pro and the map comes up georeferenced.  Pro does not recreate the .sdwx file.  

The .sdwx seems redundant...

0 Kudos
Occasional Contributor

Ok.  I found out from a colleague that your .sdwx file is actually ESRI's version of the world file.  So maybe I was confused at the reference when I was saying her computer was not creating the world file.  I meant .wld not .sdwx.  Most other software gives it the .wld extension. 

So .sdwx is redundant... 

I have been around the block for long enough (since the late 1990's) to know that ESRI has tried every way possible to georeference a map.  

0 Kudos
New Contributor II

I'm having trouble with Georeferencing in ArcGIS Pro 2.6.1. I'm working with dosens of pdf files which I convert to .tif in ArcMap. I open the tif file in Pro and the first one runs smoothly. But the next one, when i add a control point to source layer I can't pick my target point. In the control point table it has X and Y map coordinates which are in same spot as the source coordinates. Anyone has solution for this?


Steinthor Tr.

0 Kudos
Esri Contributor

Hello Steinþór Traustason

We are not aware of PDF georeferencing issues at the moment.  
Can you please log an issue with our Support staff so that we can obtain your test data and workflow please.


PS - for those that have had issues with georeferencing in previous versions, we have fixed many of these issues in Pro 2.7.  Hopefully your issues have been resolved.  If not, please log an issue so we can try to address those as soon as possible. Thanks!

0 Kudos
New Contributor III

I found this to be a one-off bug for me. The georeferenced image stayed in place after I redid all of the control points from scratch. Using a lower number of control points is optimal. 

0 Kudos
New Contributor III

I was having a similar issue with georeferencing drone orthos. Import imagery to ArcGIS Pro 2.9, align with GCPs (positions collected using high-accuracy GPS) using control points, hit Apply, watch imagery line up perfectly, hit Save, imagery stays put, hit Close Georeferencing and voila - the imagery reverts to its former (wrong) position. Do it again - same result. Lose mind. Read forum. Close ArcGIS Pro. Re-open ArcGIS Pro - imagery is PERFECTLY ALIGNED TO GCPs. Because of course it is. <sigh>. It's esri. I should have known better. It's not you. It's a bug. Just close it and open it again. It'll probably work. 

0 Kudos