Geocode Addresses in ModelBuilder

07-28-2022 12:31 PM
Labels (2)
Occasional Contributor III

I have a model, that will be run once a year to generate a report. 

Part of the model involves geocoding the address.  I am getting weird results when I run the model.  The address field is being changed to <None>, so the geocoder is returning zero matches.  I have tried deleting the tool and re-adding the Geocode Addresses tool, and it is always dropped.




As the model is only run once a year, I would like to completely automate the process.  To make the yearly report easy to generate.  Running in ArcPro 2.9.2

0 Kudos
3 Replies
Esteemed Contributor

Did you create the Address Locator with the Create Address Locator tool (old) or the Create Locator tool (new)?

0 Kudos
Occasional Contributor III

It is a organization shared locator, so I am not sure.  I am assuming it was created with the older tool.

0 Kudos
Esri Regular Contributor

@RyanBohan Does the same behavior occur if you just launch the Geocode Addresses tool from the Geocoding toolbox with the same settings and geocode the table, but then open the previously run tool from the History pane?

0 Kudos