Fiona not working from ArcPro

243
7
Jump to solution
05-26-2020 08:46 AM
Highlighted
New Contributor

I installed fiona into an environment in ArcPro and then launched it from Anaconda using Jupyter notebook. When I try to import it I get an import error. This error is being discussed on gis.stackexchange here. Their workaround was to downgrade Fiona to version 1.8.4, but I'm working from an updated version of Pro that doesn't give an option to downgrade the package.

python - Installing Fiona into cloned conda environment in ArcGIS Pro gives ImportError - Geographic... 

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor

You have to do this through conda... If you are familiar with it... 

dry run, check, if ok, remove the dry-run

--no-pin is to remove esri's parental controls

# ---- first do a dry run to see what is going to happen

conda install fiona=1.18.4 --no-pin --dry-run

# ---- Then if everything looks fine,

conda install fiona=1.18.4 --no-pin

... sort of retired...

View solution in original post

Reply
0 Kudos
7 Replies
Highlighted
MVP Regular Contributor

You have to do this through conda... If you are familiar with it... 

dry run, check, if ok, remove the dry-run

--no-pin is to remove esri's parental controls

# ---- first do a dry run to see what is going to happen

conda install fiona=1.18.4 --no-pin --dry-run

# ---- Then if everything looks fine,

conda install fiona=1.18.4 --no-pin

... sort of retired...

View solution in original post

Reply
0 Kudos
Highlighted
New Contributor

This seemed to work, but then when I had to update another package Fiona stopped working. I tried uninstalling and reinstalling the same way, and now Fiona doesn't seem to be repairable. 

ArcPro released a patch and now you appear to be able to choose Fiona 1.8.4, 1.8.11, and 1.8.13, but none of them are working. When I try installing fiona 1.8.11 from the Anaconda Prompt it says:

ArcPro had installed a different gdal, so I installed gdal 2.3.3, but I get the same error. I noticed the list of packages installed shows:

Is the problem be that it's expecting gdal=2.3.3=arcgispro_1 and it's getting gdal=2.3.3=arcgispro_11? And if that's the problem, where/how do I change the build number?

-OR- I notice the version of fiona and geopandas changes in Pro depending on what order you install the packages in. Is there a correct install sequence that would end up with a working environment?

Reply
0 Kudos
Highlighted
MVP Regular Contributor

https://anaconda.org/Esri/gdal/files 

has ...1 and ...11 versions of tar.bz

from

https://anaconda.org/Esri/gdal 

But I am on Pro 2.6 Beta 1 at present, so my "conda list" won't help


... sort of retired...
Reply
0 Kudos
Highlighted
New Contributor

I can see that the packages are installed, but when I try to import them in my notebook I'm getting the same error:

Does it seem like there's a different problem? When I search for this error I see a lot of people discussing other packages interfering with each other. I'm sharing my package list in case any conflicts pop out?

Reply
0 Kudos
Highlighted
MVP Regular Contributor

you have arcgis 1.7.1 

the current version is 1.8.1

could be the problem... I don't know the version history

You might have to go fishing on their GitHub site for Issues around fiona, if they are there

GitHub - Esri/arcgis-python-api: Documentation and samples for ArcGIS API for Python 


... sort of retired...
Reply
0 Kudos
Highlighted
New Contributor

Sorry! Your last solution worked with the new downloads! I just needed to downgrade Fiona to 1.8.4 again. Thank you for your help!!

Reply
0 Kudos
Highlighted
MVP Regular Contributor

Glad you got it to work Wendy


... sort of retired...
Reply
0 Kudos