Failed to publish Map Image Layer

891
4
Jump to solution
05-19-2021 04:07 AM
Labels (2)
GerardMartin
Occasional Contributor

Hi, 

I have to to publish a 2D points Feature Layer from ArcGIS Pro 2.5 to Portal for ArcGIS Enterprise 10.6.
I have been using "Share as a Web Layer" with parameters: CopyAllData, Map Image (no WMS)
And I get this error: "ErrorMessage: Failed to publish web layer"

I have checked SharingJobLog.log, the sharing log file in ArcGIS Pro for error messages.
It seems that Upload process failed.

 

 Status: InProgress	StatusMessage: Successfully wrote sharing info file	
 Status: Pending	StatusMessage: Sharing process started	
 Status: InProgress	StatusMessage: Sharing process started	
 Status: InProgress	StatusMessage: Successfully obtained a license from the licensing portal	
 Status: InProgress	StatusMessage: Publishing process started	
 Status: InProgress	StatusMessage: Loading manifest	
 Status: InProgress	StatusMessage: Consolidating data and staging web layer	
 Status: InProgress	StatusMessage: Creating thumbnail from map	
 Status: InProgress	StatusMessage: Using ArcGIS Version 12.3 for staging (Source for version: GP Staging Parameters)	
 Status: InProgress	StatusMessage: Stage Tool initialized	
 Status: InProgress	StatusMessage: Preparing maps and layers for processing	
 Status: InProgress	StatusMessage: Retrieving and processing fonts	
 Status: InProgress	StatusMessage: Executing...	
 Status: InProgress	StatusMessage: Executing (Available Fonts): AvailableFonts	
 Status: InProgress	StatusMessage: Start Time: Wed May 19 11:46:33 2021	
 Status: InProgress	StatusMessage: Succeeded at Wed May 19 11:46:33 2021 (Elapsed Time: 0,02 seconds)	
 Status: InProgress	StatusMessage: Succeeded.	
 Status: InProgress	StatusMessage: Consolidate data	
 Status: InProgress	StatusMessage: Staging map service	
 Status: InProgress	StatusMessage: Compressing package into SD file	
 Status: InProgress	StatusMessage: Successfully staged service (Exiting GP Stage Tool)	
 Status: InProgress	StatusMessage: Uploading service definition	
 Status: InProgress	StatusMessage: Publishing tool initialized	
 Status: InProgress	StatusMessage: Publishing web layer (AGS)	
 Status: InProgress	StatusMessage: Upload failed	
 Status: InProgress	StatusMessage: Publishing tool execution failed	
 Status: Failed	StatusMessage: Failed to publish web layer	ErrorMessage: Failed to publish web layer	

 

 

I have publish other point features as Map Image to the same Portal without no problem. In this case the difference is the size of the featureLayer: I'm working with more than 1.000.000 points, and each one has 250 attributes (more o less 1GB of data).

Also, I have check this post: https://community.esri.com/t5/arcgis-enterprise-questions/failure-when-publishing-map-image-layer/m-... but I have point feature layer stored in a fileGeodatabase in my computer

Please, does anyone know how to solve this error?

Best regards

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
GerardMartin
Occasional Contributor

Thank you Michael for your time, I have just solved the problem.

After some tests I get  ERROR 002555: The ArcGIS Data Store (relational) is in read-only mode and new items cannot be published. Please check available disk space. ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition). Failed. Failed to execute (PublishServiceDefinition). Failed to execute (Publish Portal Service). Failed.

There is a very little available disk space. I was wrong trying to publish FC copying all data in server: this  way was perfect for some tests with little amount of data but not for whole feature class.

My solution: I have copied my fileGeodatabase containing points feature class in a registered folder (fully accesible network place), and have published data with Pro 2.5 with DataType: Reference Registered Data.

 

 

 

View solution in original post

0 Kudos
4 Replies
MichaelVolz
Esteemed Contributor

Is this a hosted feature layer where the data is getting copying to the Data Store?

0 Kudos
GerardMartin
Occasional Contributor

Thank you Michael for your time, I have just solved the problem.

After some tests I get  ERROR 002555: The ArcGIS Data Store (relational) is in read-only mode and new items cannot be published. Please check available disk space. ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition). Failed. Failed to execute (PublishServiceDefinition). Failed to execute (Publish Portal Service). Failed.

There is a very little available disk space. I was wrong trying to publish FC copying all data in server: this  way was perfect for some tests with little amount of data but not for whole feature class.

My solution: I have copied my fileGeodatabase containing points feature class in a registered folder (fully accesible network place), and have published data with Pro 2.5 with DataType: Reference Registered Data.

 

 

 

0 Kudos
MichaelVolz
Esteemed Contributor

The sharingjob.log did not show the the ERROR 002555 message of read-only mode.  Where did you find that error message, possibly in the AGS logs themselves?

How do you get the Data Store out of read-only mode (delete items in the Data Store, add memory to the Data Store machine)?

GerardMartin
Occasional Contributor

Hi @MichaelVolz, I seen ERROR 002555 in another sharingjob.log after doing more tests with different parameters after asking the first question in this post. Sorry about this misunderstanding!

I have removed all hosted items in Data Store, and IT department changes mode readonly of Data Store to readwrite. You can try running the describedatastore command line tool to check to see if the data store switched into READONLY mode. And you can use changedatastoremode command.

You can see more details here: https://enterprise.arcgis.com/en/data-store/10.6/install/windows/data-store-utility-reference.htm

0 Kudos