Extrude polygons and copy and paste special into empty multipatch not working anymore.

436
5
Jump to solution
01-23-2018 06:46 AM
AlessandroValra
Occasional Contributor III

Since version 2.0.1 of ArcGIS Pro, I was able o do something which was probably not documented but was really usefull especially to those who don't have a 3d analyst license.

Extruding a polygon, and then copying and pasting (special) it into an empty multipatch featureclass would preserve the extrusion, thus leading to a perferctly nice-looking-complete multipatch!

This is not possible with the last version (2.1) anymore. The exact same procedure (tested) produces multipatch which are only more or less one meter tall (thick) no matter of the look the extruded polygons had.

Maybe this hidden functionality was not even meant to be, but since I found it out, would it be possible to know if this is a bug?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
MichaelContreras
Esri Contributor

Hi Alessandro, unfortunately this fix did not make it in time for 2.1.1 "mini-release" cut out day, but it will absolutely make it in for 2.2. In the meantime a good workaround is to change the settings for the extruded Polygons to VB Script instead of the default Arcade mode. This workaround will fix your issue momentarily when making the Copy / Paste Special into a multipatch because it will be reading the extrusion from the VB Script and not the Arcade, which is where the bug lies.

View solution in original post

5 Replies
MichaelContreras
Esri Contributor

Hello Alessandro, the functionality that you are describing is in fact a purposely made quick and easy workaround that we implemented in 1.4 and enhanced to support extrusion settings on 2.0. Unfortunately what you are seen is an active known bug of this function when the feature is extruded only. Good news is that we just found a fix for it and should be included on our next release. In the meantime, a good workaround to try is to Cop/Paste Special from a flat Polygon to a Multipatch and using the Edit > "Vertices" tool, extrude the multipatch using the interactive handles to the desired height. Also here is the link that talks more in details about editing multipatches including this neat Copy/Paste Special workflow, http://pro.arcgis.com/en/pro-app/help/editing/create-multipatch-features.htm .

AlessandroValra
Occasional Contributor III

Version 2.1.1 still not fixed. But I guess with "next release" a major release is intended (e.g. not 2.1.0 to 2.1.1 as of now but 2.1 to 2.2?).

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Alessandro... unless they are withholding fixes, the last 'release' was a mini- fix and contained minor (to some people) changes http://pro.arcgis.com/en/pro-app/get-started/release-notes.htm

0 Kudos
MichaelContreras
Esri Contributor

Hi Alessandro, unfortunately this fix did not make it in time for 2.1.1 "mini-release" cut out day, but it will absolutely make it in for 2.2. In the meantime a good workaround is to change the settings for the extruded Polygons to VB Script instead of the default Arcade mode. This workaround will fix your issue momentarily when making the Copy / Paste Special into a multipatch because it will be reading the extrusion from the VB Script and not the Arcade, which is where the bug lies.

View solution in original post

AlessandroValra
Occasional Contributor III

Thank you mcontreras-esristaff‌ for the workaround.

0 Kudos