Select to view content in your preferred language

Export Table And Copy tools constantly failing in Model Builder

06-12-2024 10:31 AM
Labels (3)
Occasional Contributor

I'm at my wit's end, please someone help. I have a model that has several instances of exporting and/or copying a table, and they are constantly failing and I have no idea why.


First step is to convert a csv to a feature table - that is the only time that works consistently. After that, I run a few field calculates and then try to export the table again, this time with a filter. Before, I had a "select by attribute", and then exported the selected records, but that also failed. Later on in the script, I join the data, remove the join and try to export or copy the result. Fails. 


The error message on all of them is "271 Cannot open the input databases"

But... the table is right there, I just did a bunch of work on it. But sure enough, if I try to open the table after I attempt to run the export table or copy tool, it fails to open. But if I open it before I run the tool, It's fine. Something about attempting to run the tool is corrupting the table. 

Any suggestions? Please help!


0 Kudos
3 Replies
MVP Esteemed Contributor

There are not bugs that match your description for modelbuilder and all your processes

Esri Support Search Results

so split your model up and only add to it when all the preceeding parts work.  

You indicate that the only thing that works is csv to feature table.

Do the calculations work? (eg stop the model there and don't add the export/copy table to it)

Does the model only work when the table is open in Pro?

Details of your input data locations and output locations would help as would a visual of the model

... sort of retired...
0 Kudos
Occasional Contributor

Sorry, I wasn't clear- the csv to feature table is the only time the "Export Table" tool works. All the other tools/calculations I run during this model run fine. It's just trying to export or copy the data where I hit a snag and I cannot for the life of me figure out why. 


Everything is being saved to the model's home gdb. So all inputs (other than the original csv the model starts with) originate and are saved in the model's gdb.


It doesn't matter if the table is open or not, it'll throw an error, and after trying to run the export or copy tool, the table becomes corrupted.

0 Kudos
Esri Notable Contributor

I found Error 000271:  Cannot open the input datasets page here - maybe this will assist with troubleshooting as it mentions something about a parameter value issue.

0 Kudos