Export map series range

333
5
07-07-2021 06:45 AM
Labels (1)
MarcelSt-Germain
Regular Contributor

I'm trying to use page range in map series with strange behaviour.

If I list all the pages, I need to export I have no problem.  If I try to group a series of consecutive pages the problem start if is't not in first place. 

No problem with this one.

image.png

But, if I make a second range, like grouping pages 5 and 6, Pro doesn't like it.  It said that the following number, 9 in my example, is a duplicated one.  I also try, after replacing 5, 6 with 15, 16 to use 15-16 and again Pro said that 24 is a duplicated one.

second serie.png

Also, if I try to make a series after the first place, like in the Pro example, I have the same result with, in the picture below, 9 is a duplicate.

autre.png

So what's I'm doing wrong?  Why can't I put more than one range nor putting the only range allowed not in the first place?

0 Kudos
5 Replies
TomBole
Esri Regular Contributor

Hi Marcel, 

"1-2" is not technically a range. A range is usually understood to be of at least 3 values. 

Why are you using a dash (-) between consecutive pages and not a comma (,)? Is there a particular reason you need to use "-" instead of a "," between consecutive numbers? 

Thanks,

Tom

0 Kudos
MarcelSt-Germain
Regular Contributor

Hi Tom,

No particular reason.  Just start to make some test.  Just use these figure to show.  Doesn't change the fact where if I try to put a range after the first place, it's not accepted.

range.png

In this exemple, now I use a long range of six pages and still have error saying that the value after the range,, 25 in this exemple, is a duplicate.

Maybe I'm to old but I think 25 is not inside 17-23.  If I change the range for single value, all is ok.

unique.png

0 Kudos
TomBole
Esri Regular Contributor

Marcel, 

Yes, at any age, 25 is not within the range 17-23.  Looks like you found a bug. Can you contact Esri Support? They can be contacted at https://support.esri.com/en/contact-tech-support.

The good news is you also found a workaround!

Tom

0 Kudos
TomBole
Esri Regular Contributor

Marcel, 

I'm able to reproduce this issue and have entered an internal bug.  If this is an issue that you wish to track please contact support.

Thanks for bringing this to our attention.

Tom

0 Kudos
MarcelSt-Germain
Regular Contributor

Thanks Tom,

0 Kudos