Select to view content in your preferred language

Explore Tool Stuck Again

1755
3
03-13-2020 08:51 AM
PeteJordan
Occasional Contributor III

  I had originally asked this last year and never got any help.  The issue just suddenly started happening again today and it's been like this all day long.  

 Simply the issue is when I'm editing, I switch between selecting by rectangle and Edit Verticies and then out of nowhere, the cursor switches to the Explore tool and nothing I do in Pro can get me out of that mode.  I can't select anything anymore using the rectangle or any other shape, I can't use the measure tool and many other things.

  The Z, X, C buttons work, but that's about it.  Not using the Webroot anti-virus software as was discussed in one of ESRI's bug reports and the only thing I've found as a temporary release is to restart the computer each time, which as you can tell is a giant pain.

  As mentioned, I haven't had this become a problem for quite a long while other than random occurrences which got fixed by the reboot, but all of a sudden today, it's just constantly locking up...

Original Thread:

Stuck on Explore Tool While Editing 

3 Replies
Katie_Clark
MVP Regular Contributor

This happens to me with some frequency as well. I have also found that the only thing that will fix it is to randomly try all the letter keys on my keyboard (today, it was 'U'). It seems to be different every single time, though I admit I haven't bothered to document the exact details of each event. 

Best,
Katie


“The goal is not simply to ‘work hard, play hard.’ The goal is to make our work and our play indistinguishable.”
- Simon Sinek
0 Kudos
PeteJordan
Occasional Contributor III

I actually tried all the keys myself as an old post for ArcMap suggested the "g" helped, but others weren't so lucky.  Either way, no key seemed to work, nor did unplugging my keyboard and plugging it back in...

0 Kudos
SDague_FSMAR
New Contributor II

Having a similar issue and posted a new thread about it.  First commenter linked me to your post.

My workaround in Pro is to use keyboard commands to save edits, save project and close Pro. This has worked for me because the Alt key still works.  This will access the ribbon interface and letter options will show on the tools to allow you to use them.  So pressing Alt accesses the ribbon, then "E" accesses the edit ribbon and finally "SV" will save my edits.  Next, I use the same Alt followed by letters or numbers to access project save and finally exiting Pro.  You can then restart Pro and the issue is gone.

Very rare occurrence for me, but the workaround above has worked each time.